Middle click paste is a problem

So I have taken note that disabling middle click past is…problematic. I have been thru posts on multiple forums, tried finding a discord server “only had discount discord knockoffs like matrix :(”, and have spoken with multiple less than helpful people in regards to making this a thing.

As some one who uses multiple art and canvas style programs where middle click acts as a scroll/zoom/grab, having it past random stuff every time I click is about the most annoying thing ever. I have seen multiple “weeks worth of” non-answers to this. With SO MANY people asking for the ability to disable it.

Is there an option somewhere that is just tucked away? A nice simple “Dont do this” option somewhere that I have missed buried under all the old posts? I know its almost impossible to git rid of in x11 but wayland was supposed to be the great white hope that fixed this. I have used a few other systems that did not have this enabled. And have seen several remarks that it is supposed to be disabled by default but that kde has re-enabled it for some reason. Is this correct? and if so how do I fix it?

big love for those with clear, concise, simple solutions. <3

Could you give an example of where this happens?
In what applications?

I know this is a feature in consoles and also in for example Kate (mark something and press mmb and it pastes that). But that is not a “clipboard feature”, ie it does not turn up in the normal ctrl+c ctrl+v clipboard.

But if I use for example Krita and press mmb, it correctly “grabs the canvas” and moves it around.

A little more specific situation so people can try reproduce the issue.

2 Likes

Obsidian.md, krita (mine does not work as yours does apparently :frowning: ), DR, Arkenforge, photopea, darktable, digicam…I’ll save us some time. For me it is any program that can accept a past function.

I will give a single example. While using comfyui “a stable diffusion front end” you middle click to grab the canvas and move it around I.E. “hand tool”. When I have a prompt or picture in my clip board middle clicking pasts that image instead of grabbing the canvas.
Obsidian.md has the same behavior and might be easier to investigate.

But any program that I have ran exhibits this behavior. </3

@medin 's solution fixed it for darktable (no idea why) but has otherwise not altered this behavior.

Also make sure that text and non text copy selection is disabled in Klipper, plus disabling synchronization between clipboard and selection

Obsidian also uses the feature, mark and mmb pastes what is marked.
Or maybe this is not per application at all because:

I can also reproduce it in this chatbox I am typing in right now using firefox, I have never noticed that before. :open_mouth:
But it only seems to work in text boxes, ie, I have to hold my mouse inside the textbox for it to work, if I mmb outside, it turns into the normal "scroll by moving mouse up/down)

It also travels between applications, ie if I mark something in for example Obsidian, I can then go to this window (firefox) and mmb and it will paste that here in the chatbox! :open_mouth:

Nothing is ever shown in clipboard.

No matter what I try, I can not reproduce this in Krita the way you describe it though. :confused:
But mmb wherever I can type text also pastes in Krita.
This makes me think this probably works in ANY text “window”.

“This makes me think this probably works in ANY text “window”.”

Which is kinda supper not what I want. :frowning:

I would prefer for it to work not at all.

@Christian_Golden , did you notice what @medin posted?

It seems clipboard is not involved in this. (unless he has that selected and that is why he can not “grab the canvas” in Krita and other applications)

Can you reproduce what I wrote?

If so, do it and check the history in clipboard, nothing is ever added there when using “mark text” > mmb.


Another question to @Christian_Golden though.
Where does the text get pasted when you try to grab the canvas?

Edit
Not sure what distro you are using, maybe worth to take a look at this: xorg - How do I disable middle mouse button click paste? - Ask Ubuntu
(the specific answer that the link goes to, not necessarily the whole thread)