Missing dependencies openai-whisper and torch

Since my wife’s English isn’t great, I wanted to give the subtitle feature a try.
For some reason I can’t get it to work.
Screenshots on the internet show an “Install missing dependencies” button but I don’t have such a thing.
So I tried to install the modules manually but it doesn’t seem to work.
I am using Linux Mint and Kdenlive 24.05.0 Flatpak.
Can anyone point me in the right direction?

Try with the AppImage from the download page: Download - Kdenlive to see if this is a packaging issue on Flatpak.

1 Like

Can confirm it’s the Flatpak causing issues.
Wasn’t possible for me to enable the python virtual environment or install Whisper dependencies with the Flatpak version.

Thanks!

Thank you for your reply,

For some reason I can’t seem te get the AppImage running.
I did set it as executable and checked again. Nothing happens when I try to open it.
I must have messed up my system somehow.

Update your Linux OS to the latest version. Then the AppImage should run.

Thank you. For now I have no opportunity to do so.
Mint 20 is still maintained but I will need to upgrade fairly soon.
I’ll keep you guys and girls posted.

Did it work without problems using AppImage?
I can’t test it right now since Mint 20 doesn’t support AppImage.
I will upgrade as soon as I have the opportunity.

Thanks in advance.

It worked without problems using AppImage for me, but I’m on Ubuntu 22.04.4 that apparently supports AppImages.

Just don’t change your audio driver to one you don’t have on your system(Pipewire in my case) in the Kdenlive settings cause it made Kdenlive confused and crash on exit and then again on relaunch(not able to open preview window or something).

So had to reset to default configuration and that fixed it again.

I thought Kdenlive showed me the audio drivers that were installed on my system but nope :stuck_out_tongue:

1 Like

Thanks again.
Tonight I gave a more recent version of Mint a go from USB.
And you are completely right! AppImage does the trick.
I could easily install the dependencies and get it to work as it should.
Since Flatpak won’t do this, I will be patient and install the latest Mint when I am ready.

Inside Flatpak it is not really possible to install dependencies at runtime.

Due to this limitation Kdenlive Flatpak doesn’t contain: Whisper subtitle and SeamlessM4T translation due to is big size.
The Kdenlive Flatpak includes vosk, SRT and OTIO.

1 Like