Monitors on TB dock do not always reactivate after sleep

I have an HP Elitebook 840 G9 running KDE Neon with Plasma 6.0.2 (although I’m not convinced the plasma version is material).

I have 3 monitors attached to the laptop. One via the hdmi plug on the laptop and 2 on display ports on the HP G4 Thunderbolt dock.

Frequently, when the monitors all go to sleep, and I wake them by hitting a key on the keyboard, only the HDMI screen reactivates. The two monitors on the dock remain asleep.

All 3 monitors will activate properly when I reboot the laptop.

I experience this behavior with both X11 and Wayland.

Any suggestions on where to start looking or diagnostics to collect?

I’ve used Linux for decades .,… but not as a workstation, only a server. So my experience with this kind of behavior is very limited.



I’ts 90% the dock. Always end up being that.

Google about that and you find all sort of information about it.

Drivers for docks are built into the kernel now, so make sure you use one that is relying on the kernel driver and NOTHING ELSE.

Yeah, that’s what I thought too …, and had the dock replaced at least once.

It doesn’t ALWAYS happen though.

And previously I was able to reactivate the monitors by disabling & re-enabling them and/or putting the computer to sleep and waking it up.

After upgrading to Plasma 6, howeber, that’s not even working.

Do you use the kernel drivers or do you have something else installed for the dock?
IIRC Display-Link is proprietary (own drivers) and Display Port Alt Mode is in the kernel and “just works”.

Does not disconnecting the dock (physically) > turning it off (if its powered) > reconnect work either?

Is it this?

That does not seem to be supported on linux, and is proprietary.

Compatible operating systems - Windows 11; Windows 10; MacOS; Chrome

You can probably get it to work, but but problems like you describe could most likely be a thing.
Sorry. :frowning:

I didn’t load any drivers.

There have been a few firmware updates for the dock installed via the linux firmware manager.

Haven’t actually tried that … will do next time it happens (probably tomorrow morning).

Yes, that’s it … but few system vendors go into details about linux support. Anyways, isn’t chrome os basically a linux kernel?

As I mentioned, there have been some firmware updates applied via the linux fwmgr, so I think HP does provide some level of support.


Android is technically a linux kernel, but the similarities are close to non existent.
They have nothing to do with each other.

I assume you mean fwupd or ubuntus fwupdmgr.

That does not mean proprietary drivers, just so you are aware.
I know there are instances of people completely bricking hardware when thinking they are installing supported firmware with it.
I don’t think you have to worry about the dock though, but it is not “official frimware” just because they exist in fwupd.

Just be aware that there is most likely not much anybody can do since it is up to the drivers, and they are closed source.

The next time you buy a dock, or anybody reading this, make sure it is supported by the linux kernel and it will “just work” 100% of the times. :slight_smile:

Just make sure it is not Display-Link

I’m curious, what kernel version are you running? You can check in System Settings or with uname -r

I’m facing similar problems with my Dell Thunderbolt Dock.
Prior to kernel version 6.7, the external displays would sometimes go black after logging in in SDDM or also wouldn’t wake up after resuming the laptop from sleep, even though Plasma thought the monitors were active. Reconnecting the dock (without turning it off) would be enough to fix that.

Since kernel version 6.7 though I’m facing a much more annoying and workflow breaking issue where the external displays will only work if the laptop was booted with the dock connected, and once I unplug the dock they won’t be recognized again until I reboot. Hence why I’m stuck on kernel 6.6

Everything in your post points to that dock using an external firmware, NOT the linux kernel.

Is the Dell Thunderbolt Dock uning Display-Link?
Checking the product page does NOT list linux.

I repeat, if you use something that is not relying on the linux kernel, there is very little to be done other than loading kernel modules (if they even exist) and hope the firmware in the dock has the correct code to work properly, and with closed source driver, I guess you just have to gamble.

ADVERTISEMENT WARNING (I have no realtion to them other than my respect for the company)
There is a company decently tight connected to KDE Neon, tuxedo.
These will ALWAYS work 100% no matter what.

100% Linux

As proven experts for Linux, it goes without saying that TUXEDO Computers also delivers the TUXEDO Triple Dock Lite fully Linux-compatible. This is guaranteed with Linux systems pre-installed by TUXEDO, but nothing stands in the way of smooth operation with common, modern distributions either.
Dockingstations - Dockingstations - TUXEDO Computers

You can also get anything on Amazon or whatever, just make sure it is using the linux kernel driver.

1 Like

Kernel version 6.5.0-26-generic

Well, the kernel has to be aware of it’s functionality at some level. It’s correctly using the displays, nic, and usb ports.

Weather or not the drivers are built into the kernel, I can’t say.

HP clearly does provide some level of linux support, as they are contributing firrmware updates for the dock to the Linux Vendor Firmware Service repository.

This shows up when I ask fwupdmgr to show me supported devices:

├─Thunderbolt Dock G4:
│ │   Device ID:          <redacted>
│ │   Summary:            Dock Management Controller Device
│ │   Current version:
│ │   Vendor:             HP (USB:0x03F0)
│ │   Install Duration:   14 minutes
│ │   Serial Number:      <redacted>
│ │   GUID:               3d044770-6074-5514-b094-3b7c5dbeb5fc ← USB\VID_03F0&PID_0488
│ │   Device Flags:       • Updatable
│ │                       • System requires external power source
│ │                       • Supported on remote server
│ │                       • Device stages updates
│ │                       • Device can recover flash failures
│ │                       • Signed Payload
│ │
│ └─DMC:
│       Device ID:        <redacted>
│       Current version:
│       Vendor:           HP (USB:0x03F0)
│       GUID:             185c2807-e871-56fd-b1a7-b638301bad5e ← USB\VID_03F0&PID_0488&CID_00

And the dock is at the latest firmware version …

Devices with the latest available firmware version:
• System Firmware
• Thunderbolt Dock G4

The dock has always worked mostly fine with Linux (like pretty much any Dock that doesn’t use DisplayLink) and only a recent kernel upgrade broke it, soooo…
Well, actually it did turn out to be a weird quirk with my dock, but a patch to the Linux kernel has already been posted to account for it.

ADVERTISEMENT WARNING (I have no realtion to them other than my respect for the company)
There is a company decently tight connected to KDE Neon, tuxedo.

Great, but their docks cost 250-350€ while I got my Dell TB16 for under 50€ on ebay, so no thanks. And in theory, guaranteed Linux compatibility is great, but Tuxedo and some other vendors are shipping “Linux” laptops with problematic power management or unsupported fingerprint readers (note that the fingerprint reader on my Dell laptop works OOTB on Linux), so I have slightly limited faith in them.

I repeat to both of you, there is not much to do since the firmware is in the dock, not the linux kernel.

You will have to ask hp, and they will respond with “the dock is not supported on linux”.
There is def people trying their best, as you see in the patch log you sent, but it is STILL only “hacks”, just like noueveu is with nvidia. It works, but it is not perfect.

I repeat, when getting a dock and you want it to be 100% compatible with linux, make sure the product page LISTS linux as supported platform, otherwise you might get what you are experiencing now.

Yes, they are super quality. :slight_smile:
I also told you you can get anything from amazon or ali or whatever, just make sure it is labeled as “supported on linux”, like this one I found after 10 seconds.
In swedish though, but you hopefully get my point. (52.15 EUR)

UGREEN USB C Docking Station