Monospace font rendering on plasma 6

I have installed Fedora 40 (with plasma 6.0.4 and QT 6.7) on my PC a couple of days ago, and noticed my terminal font to be different to my laptop (running fedora 39 and plasma 5.27.11 with QT 5.15.12). Below is a comparison. I have already checked with another plasma 6 user (on arch) and the same problem occurred. To check if this is a Konsole problem, I also tried other terminal emulators like kitty and tabby, all with the same result. For reference, in the screenshots I am using the MesloLGS NF font, but I have also confirmed this behavior with other fonts. I am using zsh with powerlevel10k for theming with identical settings on both machines. I have also noticed that the zsh autosuggestions on plasma 6 are not a desaturated color, but rather undistinguishable from the normal “already written” font (maybe this is not related to the first problem?).

I have also posted this on reddit a couple of days ago.

Plasma 5 on the left, Plasma 6 on the right:
image

The only difference seems to be the colors - the Plasma 6 uses a somewhat lighter blue color for “Color 5”. The fact that the background color is now not very black, doesn’t help either.

It is very likely that the default color scheme in Konsole has changed slightly in the Plasma 6 related mega release. If it is too light for you - go into Settings → Edit Current Profile → Appearance → Color scheme & font and click Edit. In the dialog that opens you can modify the colors to make them darker (or even compare them to the values in Konsole on Plasma 5 and copy whatever is different).

Actually, the color is not the issue. But regarding the fonts, for example comparing the “19:14” with the “19:06” on the right side, you can clearly see that the numbers are vertically stretched on the right. Also, for example the “D” of documents and desktop are different, the right one being disproportionally taller. It seems like monospaced fonts get stretched…

There’s a 1 pixel difference in the height of the “D”.

Is the renderer different? Well, obviously yes - Qt 6 had a lot of work on the render engine. Can you get back the previous renderer in Plasma 6? I believe the answer is “no”.

Hmm, I see… Would this still be a bug to report? From the comparisons I have done, this change seems to only affect monospace fonts for some reason.

I don’t think anyone will consider this a bug. The fact that the render has changed massively and as a result some monospace fonts are rendered slightly differently - does not seem like unexpected behavior to me, and the result - IMHO - doesn’t seem “bad” or even “Worse”. I might contend that the anti-aliasing is somewhat better.

I reviewed samples of MesloLGS on the web, and I think that the new rendering is more true to how it should look - the “o” in the Plasma 5 screenshot is almost completely round while in rendering I’ve seen (including Plasma 6 KFontViewer) the “o” is clearly a stretched oval.

Ok, thanks. Last question, do you have any idea what could have caused the issue with the autocompleting font not being desaturated? Or is this also intended behavior with the new rendering?

I can’t say for sure. I feel this is a colors configuration issue, as the font renderer cannot know that some text is generated by the “zsh autocompletion” and some does not.

The only difference will be what ANSI codes the terminal program outputs to the terminal emulator - and therefor what the terminal emulator (Konsole) interpret that to mean, and that is controlled by the Profile Appearanc setting.

If you can show a screenshot of how it looks (and maybe hot it looked in the past), maybe I can relate further.

Ok, thank you for your help! I will post a picture of how it looks in plasma 6 later today when I’m at home, this is how it looks on plasma 5:

Screenshot_20240507_150532

This is how an autosuggestion looks on plasma 6:

Screenshot_20240507_170730

EDIT: I think this is actually an issue with the zsh plugin I use for autosuggestions, I just experimented with color settings in the plugin and those apply only for one character, and then have no effect. I am going to file a bug report there

I have same problem with konsole + fish(not zsh). If I change color scheme to solarized, autocompleted part is does not show(but they are there it is).

Default colorscheme is ok.