Mouse clicking when typing


Can anyone here help with a very annoying problem.

When I type on the keyboard, the mouse clicks itself to the cursor.

You can imagine how annoying issue this is. This happens all the time.

I haven’t found anything from the internet, so now I’m asking help from here.

Kubuntu 23.10
Plasma 5.27.8

This could take a bit of effort.

Do you know if a certain key press causes it? Or a combination?

have you checked your accessibility and desktop effects settings to make sure you haven’t turned something on by accident.

I’ve tried to hunt buttons after typing, but I can’t find the key combination that would cause this.

I’ve also checked shortcuts if there is something that could cause this.

I’ve not found anything.

This happens when typing laptop keyboard and it happens when typing external keyboard.

I don’t have touchscreen on the laptop.

I just checked both settings, nothing found.

Do have any idea how to “track” this issue? Some kind of logging perhaps?

Actually I’ve been thinking if the touchpad is faulty…that might explain this behaviour.

I’ll turn it off and test typing.

For X11 you can use xinput like this xinput test device-name:id, to get the name run xinput list.

For Wayland you can use libinput debug-events, it shows events and from which device they come from so it would be easier to spot the faulty one

1 Like

I have now made progress with this problem.

I traced the problem to touchpad. Turning it off solves the problem.

While digging through this, I noticed an interesting thing that I need your comments on.

I tried many ways to do this and one of them was to try the Touchpad-indicator program.

Its installation failed, but something special happened. There were a lot of different settings in that Touchpad setup.

I then did an experiment today to install a clean 23.10. Well now those settings disappeared and I can’t get them back. I tried again to install touchpad-indicator, but those settings did not return.

Does anyone know how to get them? Was it a driver that I missed?

There were some really useful settings like turn the touchpad off when the mouse is plugged in and it worked really well.

The picture shows the touchpad settings.

The option to disable touchpad when usb mouse is connected is a feature of the no longer maintained xf86-input-synaptics driver, looks like you were using that before and since you reinstalled the os it probably now defaults to the libinput for wayland + xf86-input-libinput for X11

1 Like

I suggest adding an extra shortcut to toggle the touchpad. There is supposed to be some kind of default but I’ve turned on a laptop with no mouse and the trackpad not turning on; it was frustrating.

1 Like

I solved the problem by installing that synaptics driver.

This works really well and brought a few features that I need.

  1. I can now adjust the timeout value
  2. The touchpad is turned off when the mouse is connected