My taskbar doesnt show up becuase kde (xorg) thinking that the resolution is 1920x1200 when its not its 1920x1080 (NVIDIA)

No i did not remove the panel

I changed my resolution through nvidia-settings. It changed the resolution
but KDE still thinks that its running on 1920x1200 and i cant change it because
I tried changing my resolution in xrandr and i get a error

#xrandr --addmode DP-0 1920x1080R
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  41
  Current serial number in output stream:  42

I used to have a solution to this a year ago but now it stopped working please help ive been trying to fix this for 2 days now

Im running 6.8.4-arch1-1
Nvidia driver 550.67 (RTX 3060)

They say “1920x1080 (scaled)” - this also does not seem right…

If you told nvidia-settings to update you X11 configuration file, you just need to manually edit that file and undo the change. Maybe you can use nvidia-settings again to undo this.

i have many times but the problem is that the resolution is not being changed everywhere throughout the system like you see in the fastfetch and i dont know why

Can you locate your X11 configuration file and see what’s in there?

This is my X11 config file

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 535.161.07

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Files”

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"


Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"


Section “Monitor”

# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "HP LP2475w"
HorizSync       30.0 - 94.0
VertRefresh     48.0 - 85.0
Option         "DPMS"


Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “NVIDIA GeForce RTX 3060”

Section “Screen”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "DFP-1"
Option         "metamodes" "nvidia-auto-select +0+0 {viewportout=1920x1080+0+60}; nvidia-auto-select +0+0 {viewportout=1920x1080+0+60, ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24


This is my xrandr output

$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 546mm x 352mm
   1920x1200     59.95*+  59.88  
   1680x1050     59.95  
   1600x1200     60.00  
   1600x1000     59.87  
   1280x1024     75.02  
   1280x960      60.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)

I have a 16:10 1920x1200 monitor and im trying to change it to 16:9 1920x1080

Could you please try commenting out the following lines and then reboot your PC? Also make sure that you aren’t using any xrandr scripts to change the resolution.

After the reboot just to “Display Configuration” in system settings and see if you can select the correct resolution

After I commented out those following lines sddm stopped working and just stayed on this screen after rebooting of course

Oh! sorry! My bad! I shouldn’t tell you to comment the following line. Can you please uncomment it and retry?

Okay, I did it but nothing has changed for the lists of resolutions. It’s still the same as before. The resolution got reverted back to 1920x1200

I also tried doing the xrandr again and it didn’t work

OK! Then try also removing the ~/.local/share/kscreen directory and reboot.

Yeah it’s still the same nothing’s changed.

If you are 100% certain that you don’t have any custom script (xrandr) or something then I have no idea what your issue is. Sorry :frowning:

Yeah i don’t it’s fine thanks for the help though :+1:

BTW: are you aware that your monitor’s native resolution is 1920x1200?

and apparently your taskbar is showing in the last screenshot you provided but I guess I’m missing something :roll_eyes:

yes i am aware that my natives resolution of my monitor is 1920x1200

What is the issue with the taskbar in the last screenshot you provided? It seems ok to me.

If you look at the second screenshot at the bottom in the middle you will the an arrow going down that goes past the screen meaning that i cant add it to the part of the screen that’s visible which is really weird

Its that the panel disappears because the system thinks that its running on 1920x1200 when its not and i cant customize it through xrandr which kde uses

Also if i plug it to my TV this happens i dont know how to explain it
if you look closely you will see the cursor

the screen goes down as i move my cursor down
i set it to 1920x1080 on nvidia-settings