Mysql/MariaDB is missing in dependancies

Since Plasma6 upgrade :

aegir@aegir-system:~$ akonadictl start
org.kde.pim.akonadictl: Starting Akonadi Server...
org.kde.pim.akonadictl:    done.
aegir@aegir-system:~$ Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
org.kde.pim.akonadiserver: Starting up the Akonadi Server...
org.kde.pim.akonadiserver: mysqld not found. Please verify your installation
org.kde.pim.akonadiserver: Shutting down AkonadiServer...
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...

Then :

aegir@aegir-system:~$ mysqld
La commande « mysqld » n'a pas été trouvée, mais peut être installée avec :
sudo apt install mysql-server-core-8.0     # version 8.0.35-0ubuntu0.22.04.1, or
sudo apt install mariadb-server-core-10.6  # version 1:10.6.12-0ubuntu0.22.04.1
aegir@aegir-system:~$ pkcon install mariadb-server-core-10.6
Résolution                             [=========================]         
Test des changements                    [=========================]         
Terminé                                [                         ] (0%)  
Les paquets suivants doivent être installés :
 libdaxctl1-72.1-1.amd64        Utility library for managing the device DAX subsystem
 libndctl6-72.1-1.amd64 Utility library for managing the libnvdimm subsystem
 libpmem1-1.11.1-3build1.amd64  Persistent Memory low level support library, v1 runtime
 liburing2-2.1-2build1.amd64    Linux kernel io_uring access library - shared library
 mariadb-common-1:10.6.16-0ubuntu0.22.04.1.all  MariaDB common configuration files
 mariadb-server-core-10.6-1:10.6.16-0ubuntu0.22.04.1.amd64      MariaDB database core server files
Continuer avec ces changements ? [N/y] y

Installation                            [=========================]         
Attente de l'authentification           [=========================]         
Chargement du cache                     [=========================]         
Téléchargement des paquets            [=========================]         
Exécution                              [=========================]         
Terminé                                [=========================]         
aegir@aegir-system:~$ akonadictl start
org.kde.pim.akonadictl: Starting Akonadi Server...
org.kde.pim.akonadictl:    done.

Finally kmail can be started.

See 482189 – Akonadi not working after upgrading from 5.27 to 6.0

BTW I solved the problem myself.

There is just a packaging problem, the package “akonadi-server” lacks mariadb or mysql dependency.

(sorry for the “dependancy” I’ve been confused with the french “dépendance”…)

And was the solution to simply install:
sudo pkcon install akonadi-backend-mysql

or did the database need to be repopulated with Kontact settings in some way?

BTW akonadi-backend-mysql is still uninstalled. I just installed mariadb-server-core-10.6.

Then akonadi can start, and it retrieved data from old database.

Thanks Herve- mariadb-server-core-10.6 magically solved the problem
I’ve no idea what role akonadi-backend-mysql serves