Needing to set shortcut twice for it to work properly

Every time I do a fresh install I experience this issue. I has not mattered which distro I use, the behavior remains the same.

  1. I open up setting and go to the shortcut page
  2. I go to the KWin section
  3. I attempt to set the shortcut for “Maximize Window” to “Super + Up Arrow”
  4. modal informs me this shortcut is already set, and I click “Yes” to override
  5. I click “Apply” in the lower right and close the settings window
  6. “Super + Up” does nothing to any window

When I set the shortcut using the exact steps, minus the confirmation, the shortcut then maximizes the window.

Am I doing something wrong?

KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.114.0
QT Version: 5.15.12
Kernel: 6.7
Graphics: Wayland
Distro: Arch (But every distro I have tried has the same behavior)

I’ve had the same issue for some hotkeys. Using Arch Linux aswell.

Should I file a ticket? I am not immediately sure how to do that.