Neon-user-20240304-2101 hard disk encryption

When I install the neon-user-20240304-2101 with hard disk encryption I get the following message (see picture). Maybe someone has an idea what to do. Many thanks.

1 Like

Same here, had to set up without encryption which is usually a no-go on a notebook.

You can try the following command to resume the startup process:
sda2 is the root partition for me.

cryptsetup luksOpen /dev/sda2 sda2
exit

The neon should continue to boot normally.

After login, you need to fix
/etc/fstab and /etc/crypttab.
change luks-b0cb7b84-d660-4b7b-a099-53653a20b04d like device name to sda2.

neon@neon-virtualbox:~$ sudo cat /etc/fstab 
[sudo] password for neon: 
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=9A8C-FE67                            /boot/efi      vfat    defaults   0 2
#/dev/mapper/luks-b0cb7b84-d660-4b7b-a099-53653a20b04d  /              ext4    defaults   0 1
/dev/mapper/sda2        /              ext4    defaults   0 1
neon@neon-virtualbox:~$

remove keyscript option from /etc/crypttab.

neon@neon-virtualbox:~$ cat /etc/crypttab 
# /etc/crypttab: mappings for encrypted partitions.
#
# Each mapped device will be created in /dev/mapper, so your /etc/fstab
# should use the /dev/mapper/<name> paths for encrypted devices.
#
# See crypttab(5) for the supported syntax.
#
# NOTE: You need not list your root (/) partition here, but it must be set up
#       beforehand by the initramfs (/etc/mkinitcpio.conf). The same applies
#       to encrypted swap, which should be set up with mkinitcpio-openswap
#       for resume support.
#
# <name>               <device>                         <password> <options>
#luks-b0cb7b84-d660-4b7b-a099-53653a20b04d UUID=b0cb7b84-d660-4b7b-a099-53653a20b04d     /crypto_keyfile.bin luks,keyscript=/bin/cat
sda2     UUID=b0cb7b84-d660-4b7b-a099-53653a20b04d     /crypto_keyfile.bin luks

And update initramfs by

sudo update-initramfs -u -k all

update grub by

sudo update-grub

Try reboot.

2 Likes

Same behavior here, i will try all the commands below, that was sugested by you.
Thanks.

Thank you very much, it works now. I tested it today with a fresh installation of neon-user-20240307-0714. (my root partition is nvme0n1p2 and swap is nvme0n1p3)