Network-Manager doesn't show in taskbar

I recently added Plasma DE to Pop OS, which I prefer to Cosmic, but the network manager isn’t showing up in the task bar in the top right. When I go into the settings for the tray area, it doesn’t even give the option to show the Network connection.

I tried sudo apt install plasma-nm, but still can’t get it to display.

Any help would be greatly appreciated as my DDGing didn’t suffice.

Do you have a system tray widget on your panel? This is where it would normally show. If you do, then you might check the tray settings (right-click on the ’ ^',) and make sure it isn’t hidden for some reason.

If you aren’t using a system tray, you will need to add a Network widget to your panel. Right-click on the panel >> add widgets >> find “networks” >> click to add, or drag to the panel.

I am using a system tray, and I had tried what you suggested, still no Network option to display. BUT, I tried to search widgets again and this time the Network applet showed up and I was able to add it.

Thanks for the prompt response and detailed help!