New update broke the Authenticator app

Hello there!

I have been using the new KDE 6 plasma and I’m loving it. Did face quite a lot of issues on KDE Neon, but was able to troubleshoot and fix most of them using the forums.

I am facing an issue with the recent (yesterday) update I did on my Neon, it has broken my 2FA authenticator application.
2FA codes were working well till the last update, not able to figure out what’s causing the issue.

My Neon Specs:

Installed Application:

Application: Install Authenticator on Linux | Flathub
Packaging: Flatpak

And the error:

Trying to launch using terminal to get some logs:

Steps tried:

  1. Removed gnome-keyring and tried.
  2. Re-installed gnome-keyring and tried.

Unable to get my 2fa codes for my day-to-day tasks on laptop (I do have it on my phone as a backup though)
Would love to get some inputs and help resolve this issue.

Thanks!

@ngraham any help here?

Thanks!

I’m having the same issue.

If I went into KDE Wallet in the setting then loaded Authenticator app
the Secret Service Error would go away.

Though when the Authenticator app loaded there were no accounts/2FA setup in the Authenticator app.

Seams there is an issue with the KDE Wallet.

1 Like

Exact same issue. This has happened to me a couple of time on KDE Neon.

I don’t know if it’s an issue with the Authenticator application or with the KDE wallet service.

@ngraham, kindly drop your thoughts on this and give a fix/workaround for this.

In the meantime you could try using the 2FA app OTPClient instead.