No audio options Debian

Hi, I had to reinstall my audio due to audio issues, and now there are no audio options. If you know how to fix this please tell, thanks.
(I use Debian 12)

Can you please explain what you mean by “reinstall my audio”? Can you please explain what you mean by “no audio options”?

Also, can you please run this command in a terminal and past the output here: alsactl info

I had no audio working, I purged my audio and installed pulseaudio (I know that it probably was a bad idea). For no audio options, there is not audio option in the settings, and no audio in the taskbar. alsactl info does not work, this is probably because I installed pulseaudio instead of alsa.

Can you explain “does not work”? Does it give an error? What error does it give?

PulseAudio is not instead of ALSA - it uses ALSA.
ALSA is the Linux kernel audio API, and you can’t uninstall it. You can install the user tools - and that would be a bad idea (that is, if you want audio from your computer).

I’m still missing some details, and details are important - without details, I cannot help you.

When you say “I purged my audio” what exactly do you mean? I understand that in “purge” you probably mean that you ran “apt purge”, but “audio” is not an apt package - what exactly did you “purge”?

Also, what do you mean by “there’s no audio in the taskbar”? What audio do you expect to be in the task bar? The task bar shows a list of running applications - do you mean the speaker icon that shows on the applications buttons of applications that play audio? Do you not see a speaker icon on the Firefox taskbar button when using Firefox to play a YouTube video? That would be weird because that should still happen even if there’s no audio device in the system.

I ran the command to purge alsa, pulseaudio, and pipewire. I then installed pulseaudio. And By no audio in the taskbar I mean that the speaker icon in the right hand side that is used to change speakers and such is missing. I have gotten audio back, but I have to use pavucontrol to change my volume; I am trying to figure out how to integrate the audio back into KDE.

On my system, the “Audio Volume” icon in the system tray - as well as the “Audio Volume” widget, comes from the plasma-pa package.

1 Like

Is the volume icon set to be shown in the systray settings?

1 Like

IIrc pulseaudio,its qt bindings and Plasma pulse audio mixer/plasma5-pa need to be installed.

Not sure, but you might start/enable the pulseaudio server after installation, too.

Ok, am here on FreeBSD, so your mileage may vary.

Thanks, the package on debian is plasma-pa, looks like that may have been the problem, I just decided to reinstall KDE PLasma (I know not a very good decision), which also worked, I never checked to see if I had the plasma-pa package.

1 Like