No longer able to access Google Calendar in KOrganizer

Hello here,

Google calendars are not more available in korganizer 23.08.1 : unable to link to google, no configuration window opens, etc.
Was working in previous release 2 weeks ago from now.

Opensuse Tumbleweed latest, KDE 5.24.1, Korganizer 23.08.1

Easy to reproduce : Latest Tumbleweed, open korganizer, add a Google Calendar → unable to configure anything.

Thanks !

Same here with PCLinuxOS!

KDE Plasma 5.27.8
KDE Frameworks 5.110.0
Korganizer 23.08.1

It seems there are lots of problems between Korganizer and Google Calendars. Even if you have one already mapped, once akonadi starts up, there seems to be no reliable way to get it to refresh. Restarting the Google calendar under Configure Calendars used to work, but does so now only sporadically for me, if at all. Newly created events never seem to get pushed to the server. I’m about to give up on korganizer and use the calendar in Thunderbird (which I don’t normally use for email.) I h ave the problem both on Gentoo and Artix Linux.

Should be fixed with Fix google resource (!129) · Merge requests · PIM / KDE PIM Runtime · GitLab that I merged today. Now it works again for me


Yes, I must admit than google cal + korganizer is frequently broken/not reliable.

@carl, that PR is for the kf6 branch. I don’t know how soon most folks will actually be using a kf6 version of korganizer, and I know I don’t want to wait that long for this fix. I haven’t looked at the code, but do you know how easy it would be to backport to the kf5 versions? (I’m on Gentoo Linux, so I could easily apply the patch set and recompile.)

1 Like

This was backported to the release/23.08 branch and master branch. Also I asked distros to backport it.

1 Like

Excellent news. Many thanks. Hopefully this will deal with multiple problems that might well be related. If so, there should be a bunch of bugs that can be closed.

openSUSE Tumbleweed, just upgraded to snapshot 20230925, and Google Calendar sync works. Thanks!

1 Like

I hate to say this, but although things worked for a while, I now see “Can’t fetch password” for Google Groupware (not configured) in the Calendars tab of Configure KOrganizer. However, I’ve configured it multiple times. It pops up my browser to give Google permission, which I do, but KOrganizer never seems to get the message. I’ll have to check my versions and try re-compiling, but this is getting frustrating.