No more blur on transparent windows

I’m on Manjaro, KDE 6.0.5 on Wayland and I’ve always been using:

  • a custom window rule, which applied a 75% transparency to windows
  • blur desktop effect, with intensity and noise set

After a minor recent update, the majority of windows isn’t blurred anymore, resulting in chaos on desktop and not understanding anything about which window has focus. However, blur is still correctly applied to Dolphin and Settings.
I use Edna as global theme and Gently as Plasma style.

Does anyone has the same issue? Did you manage to solve or getting the desired behavior?


1 Like

Regarding your remark about which window has focus I can advise you, and everyone else for that matter, to change the following item in KDE Setting:

Window Management - Window Behavior - Window Activation Policy to:
Focus follows mouse.
As soon as you hover your mouse over another window, that window gets focus automatically. No need to click. Works perfectly.

Afaik, it was possible with the Force Blur window script installed from System Settings, which was not ported to 6.

I tried GitHub - taj-ny/kwin-effects-forceblur: Blur any window on KDE Plasma 6 and it worked fine with on X11/X12 (=Wayland) windows, however was too buggy to be set to panels and right click menus (especially in comb. with Wobbly Windows). But you don’t have to as just blur behind windows is fine.

This one didnt work for me: