No shadow from panel

Hello, I noticed one thing about the plasma panel, it is the almost complete absence of a shadow from it, is this how it should be or is it a bug on my side?

  • Distribution?
  • KDE Plasma & Frameworks versions?
  • Did you already try if this also occurs in a new user account?

The only Plasma Panel that has no shadow is the floating Plasma Panel in Plasma 5.27.x.

Sorry for not providing details.

KDE plasma version: 5.27.11
KDE frameworks version: 5.115.0
Qt version: 5.15.12
Graphics platform: Wayland
Distro: fedora 39

Yes it is occurs even in new user account

You could try X11, perhaps it is one of those Wayland bugs…

1 Like

Thanks for your reply
I tried to switch to x11 but unfortunately it even doesnt load (black screen)
so i think it’s time to get my hands dirty and fix wayland by myself :slight_smile:

I don’t know if that is a problem, or - more correctly - not by design. On my system there’s no shadow from the panel, either if it is floating or not.

What makes you think that there should be a shadow?

By default there is a shadow around the Plasma Panel so one can distinguish the panel better from the background area beneath it, e.g. if a window beneath it has the same colour as the panel’s background or if one uses a wallpaper that has the same solid colour as the Plasma Panel.
The only exception is the floating Plasma Panel in Plasma 5.27.x where the shadow around the panel has not been implemented.

If one can see this can also depend on colour scheme, a “Global Themes”, etc.

To add to previous poster i can say that white panel has a little shadow above it

I’m using Breeze Dark Plasma theme on Plasma 6 on Wayland, and I don’t see a shadow from the panel. I tried other Plasma Style themes - Breeze Light and a few 3rd party - and didn’t see a shadow on neither.

For example ‘Air’ theme has a shadow

In this post you can see that the floating Plasma Panel in 5.27.x has no shadow and that the floating Plasma Panel in 6.0.x has one:

I can’t find a theme called “Air” in the KDE store. I see a lot of themes that are called “Air SOMETHING” and tried a few but none showed shadows.

Perhaps it’s fedora preinstalled theme, sorry for misguiding.
By the way schwarzerkater
mentioned panel shadow presence in his previous post.

Also can confirm that in plasma 6.0.2 a panel shadow also absent (screen from a vm)
Screenshot_20240403_165611

Blur-Glassy-V2 has some blur - it’s quite nice (slightly transparent, taking on some background colour) and so not too bright.

Maybe just grab a ton of plasma styles and filter through them.

Rounded-Colour respects colour schemes, and is also quite nice:

1 Like

thank you for suggestions

Seems like it is not wayland problem, x11 provides the same output

I can see that blur on my system.

So my conclusion is that the Breeze styles, as well as most styles, just do not have a shadow from the panel and because its a theme option - if the theme doesn’t provide it, it doesn’t exist.

1 Like

OK…
I really cannot reproduce the missing shadow at/around the Plasma Panel

Plasma 6.0.3 - KDE neon (X11 & Wayland), openSUSE Tumbleweed & Argon (X11), Arch (X11):
→ floating and de-floated Plasma Panels both have shadows

Plasma 5.27.x - half a dozen other distributions (no Fedora ):
→ floating Plasma Panel has no shadow, de-floated Plasma Panel has a shadow

All tested in new user accounts with default Breeze light & dark !

If it is no Wayland bug (all panels have shadows for me in KDE neon Wayland ), perhaps it is something in Fedora or your individual system(s)…

Thank you for the effort!
Seems really strange because on my vm with kde neon installed i also don’t get any shadow (pic)

You maybe right that the cause of it is my hardware