No sound on HDMI

I’ve been enjoying the KDE environment for a while
I just upgraded from Kubuntu to Kde Neon 6
and at the same time I just changed my PC
The operation didn’t go too bad but I have a problem with the sound:
My pc is a refurbished HP EliteDesk 800G4 DM 35W mini pc
I connected using a Display Port cable (mini side) to an HDMI port on the screen that I had before my hardware change
Namely a iiyama B1109HDS
The screen works correctly but the sound is not active on the screen but on the mini PC
Too bad because the listening quality on the integrated speakers of my screen is still superior
I don’t know where the sound configuration is for this case.

Thanks for your help

Before I changed my PC the screen was connected via DVI + sound card output jack and the sound quality was correct

Well, the immediate idea is that if you have a sound output jack on the new device, you can use that for output in the same way as before.

But what you can also do is to make sure that your audio settings are configured to use the HDMI “Digital Stereo” profile.

I have a similar setup and my HTPC is configured like this:

1 Like

The problem is more serious than that
Because HDMI/DisplayPort does not appear!!!
While the video works

bjc49@Micro-HP:~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-3 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 478mm x 269mm
   1920x1080     60.00*+  50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      74.98    59.90  
   1280x960      60.00  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1440x576      50.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08  

It’s definitely a sound problem.
Only one card Intel UHD 630 i915

What if you press F6 in alsamixer, what does it show?

What is the output of inxi -A (or something similar)?

Output of lspci?

That’s neat - I wasn’t aware of that tool.

Though I’m more interested in the output of any or all of these:

  • pacmd list sinks
  • aplay --list-pcms
  • amixer contents

The differents output commands

bjc49@Micro-HP:~$ inxi -A
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
  Sound Server-1: ALSA v: k6.5.0-26-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
bjc49@Micro-HP:~$ lspci |grep  "Audio"
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)

My sound server is pipewire ?

bjc49@Micro-HP:~$ pactl info
Chaîne du serveur : /run/user/1000/pulse/native
Version du protocole de bibliothèque : 35
Version du protocole du serveur : 35
Local : oui
Index client : 61
Tile Size : 65472
Nom d’utilisateur : bjc49
Nom d’hôte : Micro-HP
Nom du serveur : PulseAudio (on PipeWire 0.3.48)
Version du serveur : 15.0.0
Spécification d’échantillon par défaut : float32le 2ch 48000Hz
Plan de canaux par défaut : front-left,front-right
Destination par défaut : alsa_output.pci-0000_00_1f.3.analog-stereo
Source par défaut : alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
Cookie : 54f7:6069

Excuse me for my bad english : i am french

Yes, Pipewire has replaced PulseAudio as the sound server - it works better for Wayland and also had video features. Pipewire supports the Pulse audio APIs using a compatibility layer called pipewire-pulse so all the PulseAudio stuff should just keep working as it is - Plasma audio stuff is still all PukseAudio, that API is still good enough for that and there’s no reason to change.

All the commands you showed only show that you have an Intel HDA audio codec - which I didn’t expect otherwise. The interesting question is why you can see the expected outputs? The commands I asked you to run list the outputs that the HDA codec advertised.

BTW - one reason you may not have audio through the DisplayPort is if the DP-HDMI adapter you use doesn’t have audio support. On my system I only get the “digital audio” outputs to choose from if the HDMI adapter is connected.

1 Like

It also shows both pulseaudio AND pipewire installed, and that was what I was suspecting and that could absolutely be a problem.

This also seems problematic to me
I’m looking for a tutorial to keep only pulse audio
without risking breaking everything
Maybe these commands - second part of the tutorial

$ sudo apt remove pipewire pipewire-audio-client-libraries
$ sudo apt remove gstreamer1.0-pipewire libpipewire-0.3-{0,dev,modules} libspa-0.2-{bluetooth,dev,jack,modules} pipewire{,-{audio-client-libraries,pulse,media-session,bin,locales,tests}}
$ systemctl --user daemon-reload
$ systemctl --user --now enable pulseaudio.service pulseaudio.socket
$ pactl info

Has anyone already done this return to pulseaudio?

Don’t do that.
Pulse is not deprecated, but it is not developed as something to be used on a system in 2024.
Pipewire however, it “just works”. Not only with sound, but with capturing video too for example.

Do the other way around, because as explained by guss above, everything is baked into pipewire.

Probably, there are some people that for some reason refuses to use the magnificent pipewire that “just works” and want to use the extremely old pulse instead.
How to do that? I have no idea and think it is a dumb thing to do.

Your pipewire seems VERY old, I run v1.0.4 and you v0.3.48. Maybe that is the latest version you have access to via Ubuntu?
I do not run neon, so maybe someone else that actually does can come and help better.

1 Like

thanks for your advice
I’ll leave it for today and come back next week

1 Like


I honestly thought pipewire was default on Ubuntu. It seems not.
So maybe removing it like you posted earlier is the way you SHOULD do it.

This looks promising though, but:

IMPORTANT: This is NOT officially supported by Ubuntu so far. It still may not work on some devices. Don’t do it on production machine!

I have to admit giving bad advice here in the thread, I’m sorry.

Hopefully someone that is actually running Neon can help.

If you do not want to wait, make backups and start playing around, there is no better way of learning than doing it yourself and finding out.

The current version of pipewire on KDE Neon - based on Ubuntu 22.04 - is 0.3.48. This works well for me on an HTPC with a DisplayPort connected to a TV’s HDMI port.

To remove PulseAudio and rely solely on Pipewire, run: sudo apt purge pulseaudio pulseaudio-module-bluetooth

I still recommend you check your hardware configuration with this command: aplay --list-pcms

If there is audio support for HDMI on your system, it should have entries similar to this:

    HDA Intel PCH, HDMI 1
    Direct hardware device without any conversions

And in the output of amixer contents you should see entries like this:

numid=24,iface=CARD,name='HDMI/DP,pcm=7 Jack'
  ; type=BOOLEAN,access=r-------,values=1
  : values=off

This is a hardware probe and it doesn’t matter which sound server you are using. If you see HDMI entries in the ALSA hardware probe then the problem may be in the sound server and we can investigate that more.

1 Like