Obtain old ISO or equivalent

Since I’ve upgraded my installed packages, I’m experiencing a misbehaviour in some software (Globalprotect), probably because a new version of some package is not fully compatible with the app.

I’m using KDE Neon (based on Ubuntu 22.04) as my preferred distro.
My colleagues are using standard Gnome Ubuntu 22.04 LTS and are experiencing no problems.

I’d like to download a version a little older, and test if the problem is gone or not.

I think every few days the ISO is regenerated in order to include new updates.
This behavior is normally good, but prevents me to get older versions.
I’m downloading from here.

No archive to previous ISO’s are available.

I’ve only found this, but don’t know how to use it and I don’t see any ISO.

Any ideas, please?

1 Like

Unfortunately, ISO images are not archived, unless you can find someone who has done so themselves. The second link you gave is Neon’s software package repository, there won’t be any ISO images there.

The base OS is still the same Ubuntu 22.04, so the only differences will be the ‘cosmetic’ ones from the desktop interface. Without knowing what this misbehavior is, or what Globalprotect is, it will be hard to say if the issue is related to Plasma or something else.

Have you tried starting this application from the terminal, and seeing if there are any warnings or error messages?

Probably the easiest thing to check, is to try a live version of Kubuntu 22.04, install the software there, and see if there is any difference. This would help determine if older Plasma, or more likely, stock Qt components work properly. Neon does upgrade Qt over Ubuntu’s. But not knowing much about the application, or what is happening, it will be hard to say.

1 Like

Thanks for your valuable answer.
GlobalProtect is a privative VPN software that uses Qt libraries.
I suppose some Qt library has been updated and the software crashes.
I’ve switched to Gnome Ubuntu and it works again, but I prefer more KDE Neon.

Very likely, as neon provides newer Qt than what is provided by Ubuntu 22.04. The client software probably is only tested on LTS or similar types of distros with less current versions of Qt.

It seems that they offer a command line client, which may be an alternative to consider, other than using a setup that provides software versions supported by this application. Kubuntu matching the version of Ubuntu you are using (22.04), for example.

bit late, but i’m trying it this moment with a torrent, found here:
https://linuxtracker.org/index.php?page=torrent-details&id=e5265ed305c586f0879b353038516a756340db39