Okular and plasmashell micro-freezes and full ram usage for no reason


I’m running KDE Plasma 6 (Wayland) on EndeavourOS.

I noticed yesterday, that Okular takes very long to load - instead of ~ 1 second to open up, it takes 10. Today this hit even harder, when in noticed Okular using up all available RAM at startup. I couldn’t find any bugreport around high RAM usage for okular and started investigating more.

Opening the “add widget” window also creates a freeze (high RAM usage). Clicking Icons on the task bar creates a freeze for a view seconds.

I have 32 GB of RAM and haven’t had any issue with Plasma up until now, running Plasma on Wayland.

Deleting .cache in home directory did not change anything.

Okular installed via Flatpak has no issues

Is there any cache-related issue known? I don’t know how to investigate this issue further.

With kind regards

I ran another test by adding a new user - and didnt have any issues. Narrowed it down to some style settings in Plasma and noticed the icons page taking ages to load.

The Icon Pack i was using caused the issues, updating it fixed it (the author even mentioned a fix on github)