Okular: jpg and png images are shown as blank space in PDF

I am having a recurrent problem with okular.
Since some time now, and confirmed on Kubuntu 22.04, 23.01 and 22.04:

  • okular does not render jpeg and png files in a PDF file

I have some PDF files that were created with png and jpg files. Every time I view such pages, the space occupied by the image is just blank.

I have tried to use other PDF viewers: evince, Document viewer
and all show the PDF as it should (showing the images in the pages)

I have tried many things including a full re-installation of okular, an upgrade from 22.04 to 23.01 to 24.04. No luck.

I also tried to create a new Kubuntu user with a fresh home directory but no luck either.

Any hints on how to solve this would be amazing.

Any hints on this? This looks like a bug but it could also be a configuration issue. I am at loss understanding why all PDF viewers show the pictures (jpg/png) while okular does just show blank spaces.

Thanks for any tips you may have!

Does pdftoppm documentname.pdf outputname produces visible images?

Actually no. When I do that I get all pages one by one in ppm files and the ones with images are basically blank

Then it’s a poppler problem not okular, or may be a packaging issue from your distribution.

I have Okular 24.05.0 with poppler 24.06.0, and it’s working fine.

Thanks. I have poppler-utils as 24.02, and okular 4:23.08 (and poppler-data = 0.4.12)

Do you know any way I could isolate the problem? I must say I am a bit lost here. I can reinstall okular and poppler but I have actually upgraded my system from 22.04 to 23.01 to 24.04 and nothing changed so it would be odd if that is a poppler versioning issue.

Hi all. Following the post that poppler was the problem, I did a systematic search and realised that I had poppler installed in some way (lib + include) in my /usr/local folder. Hence even the Ubuntu upgrades didn’t seem to care about that (which I guess is expected) and left it untouched.

Now I have hard-shell-brutally removed those files and reinstalled, for safety, both poppler and then okular.

And it works now! So it looks like I had a local poppler version that interfered with the system one.

Thanks a lot for helping that diagnostic!