Online Accounts Fail when logging into Google Account via Microsoft SSO

For months I’ve tried KMail off-and-on, which works fine with all my accounts (local, yahoo!Mail, GMail) except my work (university) GMail account, which is authenticated via SSO via Microsoft (I don’t understand the backend enough to really explain it well).

I can get to the point where my web-browser (Firefox) says that authentication is successful, but then the loop starts over. All I can do is continue authenticating forever, or cancel the process, which fails the account login.

I’m happy to provide any details I can, but other than the above image, I’m not sure what details might be needed. But here’s a little more verbosity:

I just apt full-upgrade’d my Debian system (from the unstable branch - but stable doesn’t work either, on a different system, with the same failure). When I restarted my computer (not requested, but it’s a workstation, not a server, so I figure it doesn’t hurt after a full-upgrade), KDE Plasma (on Wayland) acted like it was my first time to start Plasma (it wasn’t); at one point, the welcome screen asked me to create online accounts, so I tried creating my Google work account, which popped up a “Web authentication for google” window where I was asked for my email address, and then that window went blank, but my Firefox had a login window, so I finished the login there, which reported success, but the “Web authentication for google” window did not change in any way, and nothing I do can get me to a successful account creation.

I’m confident that the KDE programmers just haven’t had reason to experience a Microsoft+GMail Single-Sign-On (SSO) setup. I might note that Gnome’s similar process does end in success.

Thanks for any assistance/suggestions!

UPDATE: I just started the process over again to document it further with pictures for this post, and realized that if I don’t already have Firefox open, the Firefox portion of the process doesn’t occur.

When I then open Firefox, and come back to this site to begin this update-edit, and when I logged into this site using my Google accounts, using my work account, I was able to successfully log into this site. Those pictures are below:


I get a similar image to this when logging into the account creation, and it similarly appears to succeed with the success message as seen in the background of the first image of this series, but then it just starts looping forever without actually succeeding.

Which browser extensions do you use?
Do you allow cookies in firefox?
Do you block 3rd party cookies in firefox?

I restarted Firefox in “Safe Mode”, both before and after entering my username in the “Web authentication for google” window (shouldn’t “google” be capitalized on this window’s title bar?), nothing opened up in Firefox, leading me to believe that the login things happening in Firefox before were related to other KDE things happening rather than to the account-creation process.

So I used “sudo update-alternatives --config x-www-browser” to change my default X web browser from Firefox to Konqueror, and tried again. Konqueror did not open from the web-authentication window, nor did anything happen when I opened Konqueror manually.

When I put in a non-SSO account name to the web-authentication window, that window itself functions as a web-browser, taking me to the next step of entering a password for that google account. But when I use my SSO account name, which would normally take me to the Microsoft login screens (see pix above), the window just goes blank and does nothing.


MSFT just like google requires a lot of 3rd party domains and cookies to be allowed in order to function, that’s why I asked you which extensions do you use and whether you allow cookies.

If disabling all extensions and allowing all cookies doesn’t help I’m clueless.