Physical Righ-Click (Not 2-Finger Tap) Required - Please Help

Hi All,

So I posted a (near-)clone of this question/request in this old(-ish) thread:

  • Wayland: No physical middle and right-click on touchpad -

… a few days ago, but as that thread had been marked as “Solved” I’m concerned that people may not realise that I’m in some (desperate) need of help along the same lines, but the solution presented there is not exactly applicable to my issue.

I will apologise in advance if me “double-posting” (???) is against the rules / p!sses someone off, but I really do need the collective wisdom of the community - “desperate times call for desperate actions”. :smile:

My issue concerns the ability to physically right-click on a trackpad (not double-finger tap). The thread referenced above has a great solution, which I believe is exactly what I want, but…

…on my version of KDE (latest version of v5 on Rocky Linux 9 (latest version)) there is no “Right-click” option available.

I found this image on another site, and I believe this is what I’m looking for, but, as I said, I don’t have the Right-click options (the bottom of the list in the image) on my version of KDE. The rest of the options are the same, just no Right-click…

So I need to ask: Is there some other way of selecting this option, or a CLI way of setting it, or has this setting been moved elsewhere, or something else?

Please, this is important, as I have a physical issue with using trackpad gestures and so need to be able to turn off “tap to click” and “2-finger tap to right-click” and rely solely on the “deep click” physical actions on the corners of a trackpad.

For the record: I’ve been administrating linux servers (non-GUI) for over a decade now, but have only just recently got fed up enough with Windows 11 that I’m making the switch to KDE, which I chose because it was touted as the most configurable linux desktop (perfect for my needs). This means that I’m not afraid to dig into a system as root, but this is the first time I’ve had to deal with linux as a non-server (ie with a GUI). Its all going great; I’ve found linux versions or replacements for all the windows software I’m familial with, and the leaning curve is not steep at all - I’m just constantly tapping, etc, when I don’t mean too (I’ve got a hand tremor), and its driving me up the wall - not enough to make me change back to windows, but it’s getting close.

So, please, anyone, take pity on an old Windows laptop user and help me to get this figured out - thanks in advance



The screenshot depicts what you want to see, and not what you actually see, right?

Does the issue happen on Wayland, or only X11? If it’s just X11, it sounds like an older bug that was fixed in Plasma 6. So I’d recommend upgrading when your distro allows it, and trying again.

Hi “N” :slight_smile:

Thanks for the help.

Yes, that’s what is supposed to appear (I believe). What I get is missing the last couple of Radio Buttons.

Ahhh, I’m not sure about Wayland vs X11 (Linux+GUI “newbie”) - sorry.

But here is the (software) info from the Laptop’s “About” page:

  • Rocky Linux 9.3
  • KDE Plasma Version: 5.27.6
  • KDE Framework’s Version: 5.108.0
  • Qt Version: 5.15.9
  • Kernal Version:
  • Graphics Platform: Wayland

I hope that contains the info you require; otherwise, please feel free to ask whatever else you need and I’ll do my best to provide it asap.

Thanks again



Thanks. Can you attach a screenshot of what you do see?

Screenshot as requested - and thank you for the help