[Plasma 6.0.4] Root privileges are randomly refused via the new root prompt

Operating System: Manjaro Linux 
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.8.7-1-MANJARO (64-bit)
Graphics Platform: Wayland

After upgrading to Plasma 6.0.4, root privileges are refused in Kate, Dolphin Open as Administrator, Partition Manager, GNOME Disks…, this happens randomly, it always works after fresh login then it stops accepting root privileges after certain time.

My user is already part of wheel group.

It seems root privileges are refused only via this prompt:

While entering root via this prompt works fine (e.g KsystemLog)

And entering root password via terminal works fine.

I tried to run /usr/lib/polkit-kde-authentication-agent-1 via konsole, and tried to enter my root password in Kate, it seems there’s crash:

New PolkitAgentListener  0x5b25c81774f0
Adding new listener  PolkitQt1::Agent::Listener(0x5b25c8176e30) for  0x5b25c81774f0
Listener online
Authentication agent result: true
Listener adapter polkit_qt_listener_initiate_authentication
GSimpleAsyncResult: 0x5b25c8223370
polkit_qt_listener_initiate_authentication callback for  0x5b25c81774f0
Initiating authentication
Action description has been found
User:  "unix-user:med"
User:  "unix-user:mohamed"
Trying again
Request:  "Password: "
qrc:/qt/qml/org/kde/desktop/private/TextFieldContextMenu.qml:235:5: QML MenuItem: Binding loop detected for property "implicitWidth"
Dialog accepted
Completed:  true
Finishing obtaining privileges
Listener adapter polkit_qt_listener_initiate_authentication_finish
polkit_qt_listener_initiate_authentication_finish callback for  0x5b25c81774f0
Finish obtain authorization: true
Dialog cancelled
Finishing obtaining privileges
KCrash: appFilePath points to nullptr!
KCrash: Application '<unknown>' crashing... crashRecursionCounter = 2
zsh: segmentation fault  /usr/lib/polkit-kde-authentication-agent-1

Seems it’s a confirmed bug https://bugs.kde.org/show_bug.cgi?id=485407.

Confirm downgrading qt6-base to 6.7.0beta3 is a temporary fix for now.

1 Like