[Plasma 6.1] Did something changed in performance for Intel CPUs?

Compared to 6.0.5, there is a degradation in performance on all my laptops using Intel CPUs, the panel and widgets becomes frozen at random times, and the whole desktop stops accepting mouse clicks.

Moving cursor inside that confirmation layer, which appears when you click Shutdown/Restart/Logout, is super slow like it’s dragged by something, this was clearly not present on 6.0.5.

That new edit mode became much slower to appear and freeze from time to time when you play with widgets and panels.

Was there something changed in performance which affects Intel CPUs?


Disabling Blur effect seems to improve slowness in those confirmation layers.

Didn’t you mean GPUs? However, the same here - freshly started, the desktop is empty, no app visible, yet just moving the cursor over the empty desktop takes about 50-80% of GPU 3D engine. and the cursor is stuttering, rendering any reasonable usage of the desktop mostly impossible. That’s on Intel UHD 630.

I experienced perf issues with blur before too, but it was only in the situations, when the blur was applied on something and that something was large (like logout screen or blured visible konsole window), but now, it has problems even when it’s enabled, no matter if something blurry is displayed or not.

1 Like

I also encountered the same problem, not only the blur effect performance dropped, but the performance of screen color and KDE-Rounded-Corners was also not as good as before, especially when multiple effects are turned on and multiple windows are displayed at the same time.

1 Like

I can add some additional information. I too have noticed a significant drop in performance with 6.1 on many laptops at the office and at my home.

Everyone that was using Plasma 6.1 w/Wayland and an Intel iGPU had to be moved to Plasma 6.1 and xorg which solved the problem. NOTE: Plasma 6.05 and Wayland worked perfectly.

Everyone uses Virtual Desktops and it was terrible switching between code editors and web browsers. No issues with Plasma 6.05 and Wayland.

My Specs (my colleagues have similar or better specs):
Operating System: EndeavourOS
KDE Plasma Version: 6.1.0
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.2
Kernel Version: 6.9.6-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 16 × 11th Gen Intel® Core™ i7-11800H @ 2.30GHz
Memory: 62.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics
Manufacturer: Dell Inc.
Product Name: Inspiron 16 Plus 7610

1 Like

Same problem here. And, I found GPU loading is down(60% → 20%) after disabling monitor icc.
os: opensuse tumbleweed 20240622
kde plasma: 6.1.0
kde framework: 6.3.0
qt: 6.7.1
kernel: 6.9.5-1-default
graphics platform: wayland
cpu & gpu: i7-5700hq


Subjectively, it seems my laptop have been running hotter lately (Plasma 6.1).

Objectively, on top, kwin_wayland shows as much CPU time used as Firefox (and I use the browser costantly). It’s about 14 times the CPU time used by plasmashell, not sure if this can be some sort of benchmark.

plasmashell shouldn’t be doing much when you’re not actively interacting with the taskbar or wallpaper. On the other hand, KWin needs to process the whole tree of render objects (like windows) 60 times per second, or more, depending on your refresh rate. And also process any user inputs before sending them to applications. It doesn’t make much sense to compare the two.

Unfortunately, 6.1.1 didn’t fix the issues brought on by 6.1 with regards to poor performance using Wayland. However, it sure revealed the issues with kwin_wayland with myself and my colleagues. Many of the issues we had been experiencing (and blaming on other items) disappeared when we reverted to xorg.

The comments I’ve most heard related to laptops running cooler and less graphical issues under xorg. Personally, I had noticed greater fan use by the system (and higher resource usage) which I thought might be dried thermal paste on the CPU/GPU. All of that has went away since xorg.

I couldn’t care less if I’m running xorg or Wayland as long as I can accomplish my tasks, and I initially thought the complaints about Wayland were frivolous. However, I might have dismissed those concerns too quickly.

The thing is, I was using plasma + wayland since it was introduced as “experimental” with one of the 5.x versions long time ago, because I’m using HiDPI + non-HiDPI displays combination. And, while being still in progress, it worked pretty well. So when plasma 6.0 came out with default wayland sessions, it didn’t meant much change to me.

It’s however irony, that, while the wayland session worked solid all the time for me, it broke just shortly after it was pronounced to be stable and mature enough for everyone :slight_smile:

1 Like

Can you check if the issue persists if you disable triple buffering?


So - in my case, I can confirm that the problem was with ICC profile set. If I set it to None, it works well, if it’s set to something (built-in in my case), it overloads gpu.
I also tried to disable tripple buffering (both in /etc/environment and ~/.bashrc) and no change, the same with enabling/disabling blur.

Adding KWIN_DRM_DISABLE_TRIPLE_BUFFERING=1 to /etc/environment worked for me, the performance improved a lot, and I can use ICC and window blurring at the same time.

1 Like

Thank you for the suggest, but it did not work for any of the laptops here. Like naradoma I tried disabling in both /etc/environment and ~/.bashrc but there was no difference.

I didn’t set any ICC profile so I’m unsure where to disable that. Though, it all works perfectly in xorg so I’m not sure.

This weekend I had some time to try Wayland 6.1 and 6.1.1 on some of the different systems at work. It feels like it stresses the GPU immediately compared to xorg. I noticed the fans kicked on just loading different applications.

Most of us are using virtual desktops (I use 9) and store different code editors and other tools in each vdesktop. I am using overview (not grid) to switch between them (as I suspect most of my colleagues are as well). Just having Librewolf on vd1, Eclipse on v2, and VLC on v3 Wayland slows to a crawl switching between them. Using xorg I can fill all my vds and switch rapidly. The systems run cooler on xorg as well.

I don’t know what changed between 6.05 and 6.1/6.1.1 but something seems borked.

This is happening for me, it’s very bad. Huge performance regression after updating. KWIN_DRM_DISABLE_TRIPLE_BUFFERING=1 seems to have helped.

Operating System: KDE neon 6.0
KDE Plasma Version: 6.1.2
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.0
Kernel Version: 6.5.0-41-generic (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-4300M CPU @ 2.60GHz
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 4600
Manufacturer: LENOVO
Product Name: 20AWS3HP00
System Version: Thinkpad T440P