Plasma 6 / 5 Window Maximize / Minimize Visual Bug |Bleeding into second Monitor

Hi, i want to make this as short as possible.

(Youtube com) /watch?v=Impv2Rc2rYE

Sorry if the formatting might be a little bit wrong. And that i am posting a YT Link ^^

The video quality is no t the best, but oh well…

Used is plasma6 6.0.4 and Plasma5 5.24.7

When using two monitors, and maximizing a Window in Plasma 6 and 5, i get a bug with the Workspace animation “Maximize” by Martin Gräßlin. When dragging the windows by mouse, to minimze and maximze the window animation bleeds into the second monitor and gives all weird graphic effects. Disabling this only works in plasma 5. In plasma 6 it does nothing. I uploaded a video to YT, to show you what i mean. Is there any fix for it ?

(Youtube com) /watch?v=Impv2Rc2rYE

Thank you :slight_smile:

maybe, check and make sure that under display configuration your displays do not intersect?

i checked and tried that. in Plasma 5 you can even place the monitors with a gap. but still the same Error. In Plasma 6 you dont have this option. There the monitors are sticking together, when moving them inside the display setting.

But none of the monitors are not intersecting each other. Putting them corner to corner, just moves the bleeding to the given corner, whre they virtualy touch.

But i asked mighty chatgpt and you can appearantly place your monitor inside a virtual monitor, with Xrandr and put an invisible border around it, to block these animations from overstepping. I will try and post my take on it after work, when i am back home again. ^^

are you using wayland or X11 ? maybe it is a wayland problem ?

Okay, i just observed a few things. Yes I am on Wayand. I also tried Gnome, DeepinDE and Cinnamon, with Wayland. There is also the exact same issue. While on Pantheon X11, theres also this bug, but you can deactivate one option, to solve the issue.

UKUI DE X11 for example has none of these issues, so it defently has something to do with the animation style of these windows. So if they are “playful” or just pretty simple with no animation, when you change their size.

So i tried disabling the Maximize setting in plasma6 on X11 and it instantly worked. I Did not expext it to be this easy. ^^
When on plasma5 and Wayland, the exact same issue. So Wayland defently has a problem with this.
But also in general booth Wayland and X11 with animations, that makes the windows appear wider while shrinking, when triggering the animation.

I did not even think about X11, so thanks for that.

Remains the Question to whom to report this bug?