Plasma 6 and screen flickering in Vivaldi

I just updated to Plasma 6 which defaults to Wayland. After this update, I started seeing the screen flicker in Vivaldi. In addition, there is a significant lag in when the letters appear after I type. This seems to be specific to Vivaldi browser as this does not happen on Firefox. My graphics card is an old NVIDIA GP107 [GeForce GTX 1050 Ti] and I am using the recommended nvidia-driver-535 driver with it. Is anyone else seeing similar? Is there a fix for this?

1 Like

I have the same issue, for reference: Flickering all the time on Wayland | Vivaldi Forum

Thanks @aronkvh – looks like the solution is to choose vivaldi or wayland. For now, I switched over to X11 as it is the least disruptive option but I am going to keep an eye on the vivaldi releases in case it eventually gets wayland support.

I read somewhere (unfortunately, I did not make a note of the URL) that one can set a flag in vivaldi (or other chrome-like browsers) to support wayland. So far, this has been working fine for me.

Go to vivaldi://flags and search for “ozone”. Set the “Preferred Ozone platform” value to “Wayland” from the drop-down menu.

I will be keeping an eye on this as it appears to be a general Chromium problem since electron apps and Brave browser has the same problem. I’ll be on X11 anyway until Input-Leap fully supports Wayland which I am told will be in Plasma 6.1 when the input capture portal is merged. This problem needs to be fixed in a better way than per-application settings but at the same time it is not a Plasma problem since it concerns only chromium and Wayland. But to a novice user it will seem like a Plasma problem since Plasma 6 updates the default session to Wayland, meaning if they were not paying attention at the sddm login screen they would have switched to Wayland without realizing it.

I have this problems with some apps i’m using too. Is there a way to correct it for all of them at once ?

I’ll be on X11 anyway …

@benmordecai – I agree with you. I too reverted to using X11 for now. For me the dealbreaker was being unable to copy/paste text between an RDP session and local Plasma session. Also, I need to find a reliable alternative to xclip that works on Wayland.

I have this problems with some apps i’m using too. Is there a way to correct it for all of them at once ?

Sorry @stemy2 I don’t know if there’s a universal way to fix it. You are probably better off starting a new thread to get some attention as I marked this one Solved. Good luck!

1 Like

I’m one of those users! Also another thing that broke for me was the graphical wifi network manager. It visually worked, was responsive, detected networks, etc. But it would load forever trying to authenticate. Connecting with nmcli worked fine. Not sure if I should file this as a bug report somewhere? Switching back to x11 fixed that problem.

Do you know is there a way to change the default session to x11 instead of wayland? I have my system autologin.

I read on the interwebs that the latest update to NVIDIA drivers supposedly fix the flickering issue in wayland. I have since moved to X11 sessions for other reasons and cannot confirm whether that’s accurate.

I’m using a freshly updated arch with nvidia 550.76 and getting mad flickering across many things, most notably steam and games, so definitely not a “upgrade driver” thing. Tried starting a steam game (palworld) and the crazy flickering drove my eyeballs to hurting instantly, having to close. I just upgraded plasma from 5.27 to 6.0.4.

Rather disappointing, I keep wanting to get off x11, but wayland still remains a basketcase to try and use with KDE. I gave up trying to use it with 5.27 as the compositor would destabilize within a day or two, whereas I can usually get weeks out of xorg before I have to restart the desktop.

Actually, this comes back to the whole explicit sync thing again it seems. KDE bug #481975 states as much (can’t post urls).

Let’s hope the nvidia 555 drivers come soon to at least provide the support for fixing this for wayland once and for all. Guess back to xorg for now it is.