Plasma 6 black screen nvidia gpu GT 630 - nouveau works ok

Plasma wayland can’t start with nvidia drivers 470.239.06 on a gpu GeForce GT 630.
Is this plasma’s fault?
Is this nvidia’s fault? My gpu is 12 years old.
Should I wait for better drivers or buy a new computer to be able to run Plasma 6 ?

After struggling to update my kde neon testing, as many others I was greeted at autologin with a black screen without desktop with 3 apps open from the previous session. Only alt-tab works. And my shortcut to launch Chrome.
In konsole top shows huge cpu usage by wayland and typing is a nightmare: sssssuuuddddoooo

“sudo journalctl -b -1 -p3” shows

systemd-coredump[1259]: Process 966 (baloo_file) of user 1000 dumped core.
kioworker[1378]: ASSERT: "d->appConnection.inited()" in file ./src/core/slavebase.cpp, line 332
systemd-coredump[1389]: Process 1378 (kioworker) of user 1000 dumped core.
three stack traces
systemd[847]: Failed to start KDE Plasma Workspace.

I booted in rescue mode and on the console I tried
“startplasma-wayland 2>&1 | tee output.log”

Error: could not determine $DISPLAY.
Error: Can not contact kdeinit5!
org.kde.startup: "kdeinit5_shutdown" QList() exited with code 255
startplasma-wayland: Shutting down...
startplasmacompositor: Shutting down...
startplasmacompositor: Done.

This is with nvidia drivers 470.239.06-0ubuntu0.22.04.1
on a gpu GeForce GT 630.

I even added in /etc/default/grub to the end of GRUB_CMDLINE_LINUX_DEFAULT " nvidia_drm.modeset=1" and ran update-grub but that made no difference.

So I changed then to nouveau driver with “sudo apt purge nvidia”:
plasma 6 wayland desktop then gets loaded and seems usable.
(and to install nvidia drivers again: “sudo ubuntu-drivers autoinstall”)

I had to struggle a lot to change the display configuration from 4k to 1080p (I think I have to press shift while hovering over the apply button for 5 seconds, wait a few seconds more and then press Apply and then there is a chance that the screen gets changed to 1080p ok (instead of a scrambled screen with random pixels at the top): I still haven’t figured out the exact workaround.

With nouveau wayland I can watch in vlc one of my heaviest video’s: a few times the video freezed but continued after a few seconds. And running fullscreen in vlc fails: the top border of the vlc app is always shown. On the other hand in chrome running a youtube video fullscreen works.

If I don’t get any other showstoppers with this nouveau driver, I can live with it for the moment.

So Plasma 6.0 X11 does work with your Nvidia GPU and the proprietary drivers or do you experience the same problems there?

After you ran autoinstall, does about this system/graphics processor show llvmpipe or the GPU? I’ve had errors when it fell back to llvmpipe for some reason.
Also, you might try with another kernel version.

No, I only tried X11 with nouveau driver and only briefly. I did not try X11 with nvidia driver.
I do want to use wayland as I don’t think plasma 6 with X11 will have all the new features.

Reading all of these problems related to nvidia + wayland + plasma 6 makes me wonder:
Did it work on wayland before or is this something that happened after plasma 6 update?

I have a sneaking suspicion of what it might be but confirmation of that is needed for me to invest time.

Info Center shows graphics Processor NV108 which corresponds to the “NVIDIA GK208 [GeForce GT 630 Rev. 2]” that “inxi -F” shows.

I’m running the latest 6.5.0-21 kernel hwe 22.04.

Also forgot to tell that my screen is an LG TV 4k from 2023.

This is the first time I really will use wayland. My only previous experience with wayland was 5 years ago.
I’m surprised that the nouveau driver for my old graphics card seems to work rather well so far.
I don’t know if or when a fix comes for the proprietary nividia driver that gives the black screen without desktop.

Darn it, kinda hung on that one.

I’m not, I would not be surprised if it even works better than the nvidia one nowdays on an old card like yours.
The Noveau guys are doing some black magic fuc*ery right now, it’s amazing, I have no idea how they do it.

I’m not sure it will. My suspicion is wayland demands a proper xwayland setup, and that means you need to configure the nvidia configs more properly than most distros does. X11 has been VERY forgiving about this, wayland, not so much.
But since we can not confirm you COULD use wayland before, it is still just a wild hunch.

The reason I have this hunch, is because I have this behavior on wayland on plasma 5.27.10.

Maybe something for you to look into.

As you probably have identified you are on the nvidia 470 drivers, witch I think is correct (I did not actually check it), and I don’t think those drivers gets updated more than with security if ever needed.
The noveau are, so if it “just works” and if you get simular framerate, honestly, maybe just use those…
Oh, no you had problems with those too, well, then maybe look into trying to manually configuring the nvidia configs for x11, see if nvidia-xconfig is included in the package the distro provides. Or maybe there is a nvidia-config package to download.

I’m sorry I cant help more, I am not on the same distro base as you. :frowning:

Thanks for your reply. It’s quite possible that some config settings could make the nvidia driver work for my plasma 6 wayland.
I’m making a new help ticket for this: "What nivida config settings are needed to make wayland work?

1 Like

I’m using a GForce GTX 770 card with the 470 drivers. I had to change to x11 and
it working fine

See Black screen with cursor after updating KDE Neon to Plasma 6 - #4 by jsalatas. Does that help?

ngraham, that was one of the first things that I had tried. It didn’t help.
For now I’m playing with nouveau.