Plasma 6 Does Not Display Time

I am on Arch with KDE Plasma 6, and the system time is not showing. Nether the digital clock widget nor the lock screen. If someone knows what is wrong please tell me.

1 Like

What have you actually tried, and what went wrong? I’m on artix linux (although with open-rc and not systemd) and the standard digital clock widget works just fine, both on a panel and directly on the desktop. I don’t use a lock screen, so I can’t test that. “It doesn’t work” isn’t much to go on.

1 Like

yep, considering we are many on Arch and everything is fine. I’d say if you chose Arch you 'd better know the basics… before looking for answers and stuff in the KDE - ArchWiki .

Try creating a new User and try again, report back when you’re done.

Arch users are expected to have some basic skills - especially when requesting assistance communication becomes the main one.

We’re able to reproduce the bug in Alternative widgets (plasma 6.1): Only digital clock displays time properly.
Other than creating a new account, you could try to delete the panel and choose default panel after to restore the clock and start fresh.

Is system time ok? Does bios clock the same and, is RTC set to zero = No = UTC

$ date
Sat Jun 8 09:40:34 PM EDT 2024

hwclock --show

2024-06-08 21:40:47.338547-04:00

$ timedatectl status
Local time: Sat 2024-06-08 21:40:52 EDT
Universal time: Sun 2024-06-09 01:40:52 UTC
RTC time: Sun 2024-06-09 01:40:52
Time zone: America/New_York (EDT, -0400)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no

I didn’t actually expect responses, gave up after the first day LOL.

The system clock is absolutely fine, should have mentioned it in the original post. The digital clock widget is the one that is broken.

The analog clock is also broken, clicking on it to show the calender shows zero.

I deleted the panel, added an empty panel, added digital clock, same problem.

I have only tried removing and readding the widget, and also the entire panel now. Just tried it on a new user and same issue. I regularly run system updates. On another note, the screenshot feature also doesn’t work, so I can’t even show it. Pressing printscreen does bring up the dialog box but it just doesn’t save, or is saving to somewhere that is not the /home/user/Pictures directory.

I created a new user, started X11, which started plasma, and same issue, digital clock is not displaying anything.

Still not sure if this is a plasma issue or a clock issue. Can you install xclock (might be called xorg-xclock) and see if it works (check both analog and digital.) I also can’t tell if you have tried placing the digital clock widget directly on the desktop, rather than on a panel.

Xclock works just fine, adding widget to the desktop does not work either. Running the date command also works just fine. Only the widgets seem to be broken.

For screenshot, FN+PrtSc or PrtSc opens spectacle and the picture goes in home/Pictures (Lenovo).
Is spectacle installed? If not: $ pacman -S spectacle

In add widgets (right click taskbar), if you drag and drop analog clock to desktop, does it display time correctly. Size can be adjusted after.

If you don’t have NVIDIA, you may also try to enable unstable channels to rewrite the system. [extra-testing] is empty and [core-testing] as little: amd-ucode, linux-firmware, systemd 256-1 and few other no so dangerous: -Syu. After restart, enable [kde-unstable] to get a brand-new system.

If you have a restore point in timeshift, you may also try that.
Screenshot_20240611_211704

I do have NVIDIA.

Spectacle is installed, pressing printscreen does open up a dialog to let me take a screenshot, only it doesn’t get saved, nor can I copy it. Clicking Save As also does nothing.

I wonder if a conflicting package or shared library could be an issue. I have done a bit of modifications to shared libraries. May have possibly added different versions of libraries to /ust/local/include.

One thing sure you did something that cause this issue. Think Timeshift next time before doing modifications. Rsync works fine with XFS, make sure to select all files: home and root. Ideally, select the restore point from the app and let the process do the work.

You should get plasma 6.1 by the end of next week. Testers will get it next Tuesday or the day after.
For NVIDIA, you may wait until amd-ucode and linux-firmware (20240610) go stable in a few days, but there is no new kernel to deal with: 6.9.3 is the last and is the one you should have.
Even if 6.1 beta is mature now, keep in mind that core-testing will delete the kernel when 6.9.4 will be available. You need a second one to play safe, NVIDIA or not.

Operating System: Arch Linux
KDE Plasma Version: 6.0.90
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.1
Kernel Version: 6.10.0-rc3-1-mainline (64-bit)
Graphics Platform: Wayland
Processors: 16 Ă— AMD Ryzen 7 5825U with Radeon Graphics