Plasma 6 - Krunner Failing to start - message recipient disconnected

Hello all, I originally had the krunner failed to start because service file wasn’t installed. I added the service file, but now I get the error:

Launching Krunner (failed) Message recipient disconnected from message bus without replying.

I’m on kde neon. If I try to run krunner in terminal, I get:

Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QObject::startTimer: Timers cannot be started from another thread
ASSERT: “!identifier.isEmpty()” in file ./src/runnermanager.cpp, line 692
KCrash: Application ‘krunner’ crashing… crashRecursionCounter = 2
KCrash: Application Name = krunner path = /usr/bin pid = 8761
KCrash: Arguments: /usr/bin/krunner
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi
QSocketNotifier: Invalid socket 6 and type ‘Read’, disabling…
QSocketNotifier: Invalid socket 20 and type ‘Read’, disabling…
kf5idletime_wayland: This plugin does not support polling idle time

[1]+ Stopped krunner

Thanks for any help!

See Plasma 6 Upgrade - KRunner failing to start - #6 by bovender.

I’m really sorry this happened. The roll-out of Neon’s packaging of Plasma 6 was unacceptable, and we’ll be conducting an investigation to determine how it happened and make sure it doesn’t recur.

Hello, I don’t know if you read my post closely, but I already tried the solution in the link you link to, but it doesn’t work for me. I’m still not able to get krunner working.