Plasma 6 moving icons on panel


Since updating to Plasma 6, the icons on the panel regularly move to the far left. The problem occurs under Wayland and X11. I have an nvidia GPU.

Does anyone else have the same problem?


Can you please create a new user and check if the issue persists?

A other user wasn’t affected indeed. So I’ve wiped a lot of cache and config files. The issue is gone but now plasma is quite unstable and I can’t logout properly. Any idea how fix this too?

For the logout issue either see: 481938 – Unable to leave session via Desktop menu on Plasma 6.0.0 for a workaround or scroll a little bit down in the forum. There are tons of posts :stuck_out_tongue:

As for “unstable” you need to be more specific.

I don’t meant this issue. I’ve fixed this already. When I try to logout I get a just a black screen or plasma starts again. I’ve observed both.

Unstable means that plasma crashes frequently, mostly when I click on the panel.

The logout issue seems to be resolved but I have still the panel issue. 2 or 3 clicks on the menu button or on the systray crashes plasma.

The X11 session is not affected. But I’m still surprised whats different on my user profile.

EDIT: A click is not necessary to trigger the bug. If I hold the cursor a few seconds on the panel plasma crashes. Only the task list area of the panel is not affected.

The original bug happened again. It seems to be related to the compositor mode. It was software rendering when the bug occurred and vanished after I’ve changed the mode.

At the moment the wayland session is stable too. So I think both issues are related to the used compositing mode.

Can anyone tell me how to change it when there is no icon in the systray informing you that kwin runs in software rendering mode?

On a different computer with a different user profile I’ve observed a even but probably related issue: plasmashell was crashing directly after been started. This was triggered by some .desktop files located in the Desktop folder. The issue was gone after deleting them.

I could never get this to work on my own system with just cache clearing and config resets. I resolved this by changing the Plasma Renderer “Rendering Backend” to “Open GL” instead of “Software”. It seems like sometimes the Plasma Renderer settings widget resets back to the “Software” backend, perhaps on system updates, so I override the system defaults with my own settings like so:


[QtQuickRendererSettings] RenderLoop=basic SceneGraphBackend=opengl

This was part of the (rather annoying) ‘solution’ for me. I created a new admin user, logged in on that account and copied over the entire ./config directory over to the defective actual account. Chowned everythin, and now I have to redo pretty much all settings, but at least the icons are staying put.