Plasma 6: One of my three monitors is black on login


I run Arch Linux and Plasma 6 Wayland.

KDE Plasma Version: 6.0.2
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.2
Kernel Version: 6.8.1-arch1-1 (64-bit)

Driver: nvidia 550.67-1

Two days ago, I plugged in a new Dell monitor and it worked great. Yesterday, it also worked great, though I updated my system at some point (several hundred K programs were upgraded, but not plasma-desktop and other plasma- packages; they were upgraded 9 days ago).

Sometime between then and now, my monitor display is black while still being on and detected:

This monitor is mistakenly detected as being my main monitor when GRUB launches, so it works fine. It is the only one of my three monitors that does not show anything when SDDM starts up. However, when I login, it does show the KDE loading cog splash screen before going black again.

I checked my logs with sudo journalctl -b but I can’t find anything relevant…

Any ideas?


The one thing I didn’t try was unplugging the cable and plugging it back in again. The monitor displays now!

Worth mentioning on the hardware side:

  • There is a HDMI cable running between my GPU and my monitor.
  • On the GPU side, the HDMI cable plugs into a HDMI to DisplayPort converter.
  • On the monitor side, the HDMI cable plugs into a HDMI to DVI (?) converter.

Does that fix the issue permanently, or does it come back every time you power on the system and then you need to unplug and re-plug again?

If the former, then probably the cable was seated wrong. If the latter, it’s probably a bug in KWin and I would recommend submitting it at under the kwin | multi-monitor product.

I powered my system on again today, and the monitor worked correctly all the way through. That would suggest the cable wasn’t seated correctly, but that doesn’t explain why the monitor displayed some stuff consistently yesterday…

For a point of comparison, I dual-booted into Windows 10 yesterday for a few hours. About an hour in, the monitor started flashing black, alternating between being my third desktop and being completely black, and a bunch of other visual glitches. I ended up needing to unplug it and turn it off. That seems more like a cable seating issue to me.

I can’t reproduce it, so it seems likely it was actually an issue caused by the cable being seated incorrectly. I’ll file a bug if I can reproduce it again.