Plasma 6: Task manager doesn't save new apps

Hi,
I’ve seen a new problem (at least for me).
In the task manager (set as Icons only), if I add a software and then I reboot, it doesn’t save what I’ve previously added.
As task manager I mean this
Schermata_20240303_095323
(where you can see that I’m missing an icon, in this case is Firefox, anyway this is another problem I haven’t been able to solve yet)

What should I do to make it works?
Thank you in advance.

Do you by any chance have any modifications that could interfere with Plasma saving changes to its config files? For example are you using FireJail or AppArmor or anything like that?

No…nothing like that…at least not I’ve intentionally choosen.
I’m, more or less, with a default setup, just added a “color picker” (now I don’t remember well the right name) to the panel.
I’ve already tried to delete the panel and readded it, then I’ve also changed the theme and on the last change I’ve choose to reset all the defaults.
If you want to drive me to check some logs, you should suggets me where I’ve to look as I’m not a KDE (or Linux) expert… just installed Neon in the past August.

Sounds similar to 482469 – Plasmashell does not remember desktop icon size or programs in the panel, which was reported by a Gentoo user.

I can’t reproduce the issue myself. :confused:

Could be…
I’ll try that suggestion to check the file permissions on that folders… I hope to solve…

I don’t know what I’ve done (probably Neon latest updates do something? ) but it seems that now it saves the program I add in the panel

after some reboot I can say that now it’s solved.
Just for anyone else that could be still with this problem, I can report something related or not with this issue.
I remember that I’ve tried to drag&drop the missing firefox icon to the desktop, then I remember I have choose (but not sure about this) to moved (or copy) the icon, then I’ve launched Firefox and “magically” I’ve seen the Firefox icon substitute the missing icon, meanwhile Firefox asked me if I want to consider Firefox as default browser (strange thing that I’ve never changed before), then I’ve opened the launcher (from the KDE icon on the panel), searched for Firefox, right click and choose “add program to task manager”.

More or less this is what I did… I really don’t know if I’ve unblocked something or simply I’ve overwrite something with this…or if it’s just a coincidence… anyway now seems ok.

I’m having this issue on both my baremetal desktop (Artix Linux, updated from Plasma 5) and my VM with a fresh install (also Artix Linux).

Any added or removed pins are reset to default upon relog/reboot.

I see from the linked bug report that this may be related to not using systemd, which I am not, so I’ll head over there!

Issue for me as well on OpenSuse TumbleWeed with KDE 6.0.1.

Once I get the update for 6.0.2 I check it see if it works. Happy to provide any log files that maybe helpful for debugging.

EDIT: Literally after I got done writing this I updated my system and rebooted and now it is working. Same version of KDE but one of the libraries TumbleWeed bumped may have fixed it.

I had the same problem. A workaround for me was to switch to a Plasma 6 X11 Session and then pin the applications to the taskbar.

1 Like

bluebomber182’s solution, switching back to X11 temporarily to make changes, worked for me. These changes persist after going back to Wayland.