Plasma 6 Update problems

Just upgraded to kde neon plasma 6 , after rebooting I am presented with a half screen virtual keyboard, after managing to login, the shutdown and reboot buttons no longer work. Thought I would try it on a virtual box , but that has frozen - even after several attempt.
Very disappointing

1 Like

Look here for quick fixes for the login stuff.

1 Like

I’m really sorry this happened. The roll-out of Neon’s packaging of Plasma 6 was unacceptable, and we’ll be conducting an investigation to determine how it happened and make sure it doesn’t recur.


Hi, After experiencing these issues I tried to make a virtualbox vm but could never get to the login screen just blackness. Next step clean reinstall with encryption. The encryption failed, second clean install worked but now there is around 20 seconds of black screen after logging in before desktop is shown ( this also happens on my wifes laptop)
Now running Kbuntu hopefully neon will become usable soon

I’ve tried to update a basically unmodified neon image (neon-user-20230214-1145) in a VM. around 900 MB system update.

plasma 6

system broken. grub not showing up at all, sddm falls back to defaults, login to desktop fails after some seconds and falls back to sddm.

update on my prod system:
on hold :frowning:

shutdown from sddm works like a charm

switched to console
$ sudo apt autoremove
$ sudo pkcon update
$ sudo reboot

this way the update went smooth, plasma 6 running in X11 now.
no idea what the difference is


first of all, many thanks to the developers for their work. After solving the shutdown, restart and exit problems by adding two files to usr/share (thanks to Bruno for this), I still have two problems:

  • Discover can only be opened once per session

  • LibreOffice integration is missing.

Thanks for future solutions.

LibreOffice integration is a Kubuntu package package I believe, no Neon.

Did you get a resolution for the Virtual Keyboard showing at login? I have the same issue and its getting annoying

Not a real solution, but using lightdm instead of ssdm fixed it until , its properly looked at

@Obscure.username73 , I had the virtual keyboard showing at login, and it turned out just to be because I was using a themed login screen that was no longer supported.

Going into Settings and selecting default Breeze Login and Splash screens fixed it for me.

Ah ok. Ill give that a try. Thanks for your reply