Plasma 6 Upgrade - KRunner failing to start

Here is the message I get when using my shortcut to fire off krunner:

Launching KRunner (Failed)
The name org.kde.krunner was not provided by any .service files

See if anyone here can beat me to finding the fix for this one. Thanks!

Check if the krunner service file is on your system. /usr/share/dbus-1/services/org.kde.krunner.service

If not create it and add

[D-BUS Service]

That was it! I was getting there but I didn’t know what the file content was. I saw that plasma-workspace is listed as the provider of it, but it isn’t isn’t the .deb file for Neon. Thank you!

This sounds like a Neon packaging issue; please report it to them!

1 Like

Reported 481940 – krunner not launching due to org.kde.krunner.service file not installed.


Same here, also on KDE neon, issue was fixed for me by manually creating that file. :+1:

1 Like

I tried this solution, but after I added the service, I get a krunner error:

Launching Krunner (failed)
Message recipient disconnected from message bus without replying.

1 Like

Worked for me. Thanks so much!

I’m really sorry this happened. The roll-out of Neon’s packaging of Plasma 6 was unacceptable, and we’ll be conducting an investigation to determine how it happened and make sure it doesn’t recur.