Plasma Bigscreen and “Resolution not Supported”

This is definitely a bug, and I plan to report it. For now though, I want to know if I’m just missing a dependency or something like that.

I’m relatively new to Linux, and wanted to replace my smart TV with Plasma Bigscreen

I am using Debian 12 with Plasma Bigscreen on an intel NUC (I don’t think specs are important). Everything works fine on my computer monitor but not on my TV (Vizio, Model Name: D43-D2, Version: V2.1.18.0888_143)

I’m fairly certain the problem is with Bigscreen itself because my TV works fine with good old KDE Plasma. But to narrow the problem: in x11 plasma Bigscreen my TV says “no signal”, on Wayland Plasma Bigscreen my TV will do one of two things when it’s turned on.

1). Flicker: the screen will be on for anywhere between half a second to half a minute then it will go black for a short amount of time. The time intervals are completely random.

2). “Resolution not Supported”: my TV throws an error on screen and doesn’t do anything more.

Things I have tried:
1). Someone said it could be a p-switch (I think) problem. So I changed the settings via terminal to 0 (I’m sorry if I got that wrong, it was a bit ago)

2). Someone on the internet said they were able to fix a similar issue by changing to a legacy bios rather than UEFI. They don’t know why it worked. I tried that, but had an unfortunate surprise; The NUC I have won’t allow my ssd to boot in legacy bios.

3). I’ve tried “sudo apt-get upgrade” and “sudo apt-get update” in that order.

And to reiterate, it works fine with my computer monitor.

Anyone have any idea what could be wrong and how I might be able to fix it?

In case this is important to finding the answer, I got Plasma Bigscreen on Debian by:

1). Downloading a live KDE Debian ISO
2). Installing said ISO
3). Sudo apt-get install plasma-bigscreen
4). Sudo apt-get update, sudo apt-get upgrade, sudo apt-get update (for good measure)
5). Restart and go into plasma Bigscreen via the login menu.

That sounds a lot like HDMI TV blanks every few seconds when set to 4K 120 Hz on 6800XT (#2966) · Issues · drm / amd · GitLab

Thank you for your help, but I have already found a solution on my own.

Big screen looks like it works better with Manjaro on x11 than it does with Debian. I switched and it’s working fine now.