Plasma Bigscreen first steps?

I’ve installed the Manjaro ARM build of Plasma Bigscreen on my RPi4. It boots and brings up the DM but I’m stuck there – it’s prompting me to select a user and enter the password but there don’t appear to be any users available. Attached is a photo of the screen I’m seeing:

I’ve tried clicking on the arrows and changing the DE type to no effect. Instructions are extremely sparse – does anyone know what my next step ought to be here?

1 Like

You can do a Ctl+Alt+F1 to get to a tty and add a user. I don’t know which of the F keys Manjaro uses, so it may already be on F1. If F1 doesn’t do it, try another.

1 Like

So Ctrl+Alt+F3 worked, but it’s asking for login and password right away.
Is there a way to cancel that, so we can add a user?
Entering sudo it just assumes I am typing username :slight_smile:

Also tried editing /etc/passwd file from my linux laptop… Problem is I have no idea about adding user that way…

Really want to test this, good thing I didn’t install on SSD right away.

Alternative is debian package through synaptic store on latest Raspberry pi os Bookworm. Installed, but I have not managed to launch that yet, as I am configuring on older RPi 3B+, while Pi 400 is in use.

Yes, it will need you to log in, each tty is a separate thing. If root is not disabled, you can just login as root and then create the user and put them in whatever groups you might need. You said Debian.

No debian package is 2nd alternative attempt of getting the same plasma-bigscreen running…
I had more hope in image that already had it, which is manjaro-arm based.

Root is enabled , just don’t know the password…
root root didn’t work, neither did root manjaro or anything I could think of…
Also reading more I found: “If the user does not have a password, then the password field will have an * (asterisk ).”
So I will try to make root have no password…
Back in that /etc/passwd I assume… Or also etc/shadow.
Good thing I have a working linux install already, cuz you can’t even access root partition from windows.

I’m sorry. I thought you were running Debian. You have a different username, so I was not aware I was talking to the OP. I was confused.

Well you are not, I just happen to have the same problem as OP, maybe later build…
And I a have a version of debian too on different drive, but that has other problems. If I fail changing password of root, then I guess I will focus on debian…

You really should have started a new thread. :slightly_smiling_face:

At this point, I don’t even know what distro you are on. I am now guessing Manjaro? You need to ask the Manjaro forum how to edit GRUB to get you into a root tty when your root user is deactivated. So that you can give root a password and use it.


Yeah root user without password was never gonna work…
Giving up on plasma-bigscreen for now.

No need to give up:
Chroot into your system using a live CD and then change the root password or add another user.

Other examples: Reset lost root password - ArchWiki

1 Like

Yeah I checked and live CD would have to be the same architecture.
Didn’t have time to test, but other examples look interesting.
Would have to be added into cmdline.txt I assume.

I am really learning new things, managed to change root password. Now making new user gotta be super simple.
And it also somehow booted on RPi 3B+, even though I was sure it was Pi4 image :slight_smile:

sudo useradd
did it’s thing, and then
passwd “username”

But for further testing I will have to find time when Pi 400 is not in use… Login didn’t work on Pi 3, but at least I could select user now.


Setup wizard being broken really doesn’t help…
Login fails on Pi 400 too.
Maybe default user group is not the one expected, but this really starts to look like a dead end.

People had better luck with 2020 beta images, but those didn’t support USB boot.
Converting old beta image into berryboot compatible image worked, now it boots from USB. First time running Plasma Bigscreen. Even though image was called Mycroft something… Time to test :slight_smile:

And now I know it wasn’t worth it, web browser doesn’t connect to internet other “skills” a.k.a apps don’t even start… Not all buttons on my tv remote are recognized…

Never wanted the audio assistant part, just CEC tv remote control and maybe a web browser that works with tv remote too. Wireless mouse isn’t always perfect.
Been trying so many things.
Android on Pi, not stable enough.
MOVIAN even less stable.
KODI the later the build, the worse it gets, devs can’t even add keyboard input languages fast enough. Plus I think KODI has killed one of my SSDs…