Plasma Bigscreen on x64

I’m trying to set up plasma bigscreen on an arch x64 installation. I grabbed plasma-bigscreen-git from the AUR, which builds from latest sources.

When I start a plasma-bigscreen-wayland session, it first appears to work correctly (showing the kde loading screen with the spinning gear). But then I only see a grey screen with a cursor on it.

I can move the cursor, and the top left corner shows the typical “active corner” highlight, but no interaction is possible. Neither click nor right click anywhere does something.

If I wait a few minutes the lock screen turns on, showing a background image and the time and date.

I tried Wayland and X11 with the same result.

How can I debug this setup? I tried to find logs somewhere, but was unsure where to look.


I’m barely starting experimenting with bigscreen myself, so I’m probably not going to be a lot of help…

The first thing you can do to get some logs would be to attempt starting bigscreen from the console within an already opened session, using the plasma-bigscreen command.

As for whether these logs are gonna tell us anything interesting, I guess we’ll find out !

➜  ~ plasma-bigscreen-wayland
org.kde.startup: "kdeinit5_shutdown" QList() exited with code 255
startplasma-wayland: Shutting down...
startplasmacompositor: Shutting down...
startplasmacompositor: Done.
➜  ~ plasma-bigscreen-x11
$DISPLAY is not set or cannot connect to the X server.

different errors for wayland and x11, neither starts