Plasma cursor settings override Konsole

I want to use a block cursor in Konsole. I have it selected with the current and default profile, but I believe that the plasma cursor settings are overriding it, but not positive.

When I go to the cursor settings in Konsole and select the block, it appears fine, but if I change applications it goes back to the ‘I’ beam. I have the cursors set to Breeze in the system appearance settings.

Is there any way to make the Konsole cursor settings stick?

Turns out that something else was changing the cursor. zsh-vi-mode makes the cursor a line in insert mode.