Plasma-discover not launching

plasma-discover will not launch, tried from command line nothing as standard user is reported, but as root

sudo plasma-discover

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
libs QList(“/usr/lib/x86_64-linux-gnu/qt6/plugins”, “/usr/bin”)
org.kde.plasma.libdiscover: OdrsReviewsBackend: Fetch ratings: true
adding empty sources model QStandardItemModel(0x5d830f406f80)

1 Like

I have the exact same problem.

Have you found any solution??

1 Like

No response yet, odly this is a new install, I will try a rebuild and see what broke it

Exactly the same here…
and also mentioned on reddit without a good solution “discover_doesnt_start_up_on_plasma_6_in_kde_neon”

very strange
only since plasma 6…
hope it get’s stable very soon

Mine happended on a fresh install after I finished tweaking it. Did a complete reinstall made same tweaks and installed same apps etc, works finw, all very odd

I have the same error on KDE Neon.

I have the same problem too :frowning:

In my case plasma-discover launches only from Konsole.

it seams this is a bug and it is reported here:
https://bugs.kde.org/show_bug.cgi?id=481993

what is still very strange is that, as mentioned in another help item:

discover can only be opened once per session

and it is still the case. If I’m lucky, I can open it once. Is there a kind of debugging I can do in both cases to find out where it is going wrong?

Just rebuilt my system , installing things one at a time and using timeshift to roll back, everything went well until I installed, rhythmbox, filezilla or bluefish. After that discovery failed. Installed them vis flatpak and all is well.
Very odd

1 Like

Don’t run Discover as root. This isn’t supported and may cause the problem you’re experiencing.

1 Like

To run discover as root is giving the message mentioned in post 1.
The problem is that in the other cases nothing happens…

I’ve recorded my screen (and as recordings are not allowed I made printscreens)

  1. when clicking in GUI - bouncing icon stopping after a while with no additional visible action.

  2. when using terminal, wtihout and with sudo (when using root - no process is started). Same result: nothing happens, so Ctrl+C to stop the process

  3. PrtScr of processes. There is a process starting with every action.

So you’re right about the root. But the problem is still there and discover is not opening. I cannot figure out if or if not there is already a bug reported or a way to solve this.
If there is any way to get (annd give) more information I would love to…

since not having rhythmbox, filezilla or bluefish installed I don’t have any problems. perhaps one of the dependancies breaks the system ???

Through Synaptic I don’t have any of those applications installed and I can’t run Discover. I guess they could have been installed via Discover before it became inaccessible.

Synaptic will show any package that is installed by Discover (except Plasma extensions, Flatpaks and Snaps AFAIK).

plasma-discover is launching again!
I was hesitating to report this, but now, for 3 days in a row I can open and close plasma without any problems.

Thx for the hard work kde/plasma/neon team! I can imagine that some would have preferred to see the upgrade to plasma 6 run a little more smoothly.

With the latest Synaptic update I’m back up too now with Discover as well.