Plasma doesn't remember second monitor position

When using the meta + p shortcut to enable my second monitor (the only obvious way AFAIK) the only options to extend are extend to the left and extend to the right which resets whatever position i had set before.

Any way to have plasma remember the last position?

System info:
Session: Wayland
Plasma: 6.0.4
Frameworks: 6.1.0
Qt: 6.7.0

Meta+P shouldn’t be required to enable the external monitor every time. It’s supposed to remember its enablement status.

if you enable it in System Settings > Display and Monitor, click Apply, and then unplug it and plug it back in, is it not getting enabled?