Plasma Mobile is almost daily driveable (for me)

I was recently trying to move to plasma mobile (postmarketOS on OnePlus 6) and got pretty far. I was still going to dual boot it with android, but Android will be a backup in case things break.

And I didn’t have a lot of roadblocks. But there were some.
And I made a list of thing which should be looked at.

Road block 1: Sleeping
The phone won’t wake up if I have a clock alarm or receive a notification.
Maybe waking up every minute or so to check notifications can work.

Note: It should work for calls on pmos

Road block 2: Battery life
When idle, it is close enoght to android, but when running YouTube Music for example it is maybe 3 times worse.

I found that using powersave governor works fine. UI will lag, but music won’t.
So step 1 will be using powersave governor while the screen is off.
Also at idle it is at 1.8 GH which is too much. Maybe ondemand governor can fix it?

How did I get some apps like YouTube to work

PWAs (which stands for Progressive Web Apps)

They aren’t as good as native android apps, but they are better than using waydroid.

I was using angelfish for PWAs, but then switched most to Firefox.
Firefox doesn’t officially support PWAs, but there is an extension for it. If you are able to compile it for a musl system like postmarketOS. I switched because icons and ad block work on Firefox, but not on angelfish.

This works for YouTube, YouTube Music, GMaps, Google Translate and Telegram.

I also installed Telegram Desktop because it can send notifications.
(maybe Firefox PWAs can also send them, but angelfish can’t)
I had to change scaling to 255% to be able to see what I am writing and force GNotification in settings (it’s bug also on desktop).

For Google 2FA, you can use Keysmith.

And now the list of resolved or minor problems:

  1. Text wraps too often in the terminal (solved by using a 2 line prompt, e.g. tide + fish)
  2. angelfish doesn’t show icons for PWAs (switched to Firefox)
  3. I can add Nextcloud to account, but I can’t find files.
  4. Captive Portals (solved by using Firefox, which will open them)
  5. Editing text behaving weirdly (sometimes duplicates or removes parts)
  6. angelfish can’t use location (Firefox can)
  7. Keysmith can’t paste from clipboard
  8. Circle from the volume slider should be higher res (looks pixelated at 300% scaling)
  9. Clock doesn’t wake up the phone
  10. Clock doesn’t play a sound when it is changed
  11. Clock volume is system volume
  12. Notification popup is offset to the left and not mobile friendly.
  13. No vibrations for notifications, only sound.
  14. On screen keyboard vibrated too much.
  15. Sound doesn’t work for the on screen keyboard
  16. Wi-Fi won’t autoconnect (sudo nmtui then edit connection and allow all users)

Not plasma mobile problems:

  1. 5G Wi-Fi not working.
  2. Waydroid yeets battery and memory (yeet waydroid of your phone)
  3. Double tapping on the screen wakes up the phone, even if the phone is in the pocket


Before all, tbh, I daily drive it a PinePhone for almost 2 years now (and monthly re-flash it lol). Also Bart from pmOS is daily driving it.

First, about the sleeping, it’s 1/2 true. Sometimes it wake up, sometime not. The thing that is sure, is that calls are just freezing the whole system.

About battery life, I can only agree. The battery usage is the main issue, and when you add that to PinePhone low battery, sometimes that’s hard. But just always take an external battery with you.

About YouTube, that’s not my major issue, but some thoughts about it. When I was still on Manjaro, I used to use FreeTube, which is responsive on mobile. I’ve switched to pmOS and kind of forgot to install it, even if PlasmaTube is not doing an incredible job (at least on my phone).

For me worst is AudioTube, I don’t know why but every actions takes 1 minute to be triggered, and you can’t anticipate because the waiting queue is very long also. Just to try to search a music and wait for it to be loaded.

Now the list of bugs :

  1. I never had that problem, but great that you found a solution
  2. It worked before Plasma 6, sometimes a reboot was needed, but since Plasma 6 it is impossible to register to a captive portal.
  3. I mainly occur this on Angelfish URL field, but yeah, that’s one of the weirdest things of it.
  4. So I’m not the only who noticed it. That’s sad because Action Drawer is almost the only smooth component.
  5. As I said above.
  6. Bad for wake-up.
  7. Bad for class surprises after wake-up.
  8. That occurs since PM6.
  9. Imho that is not yet configured, but not sure.
  10. Go to your virtual keyboard settings.
  11. Is this expected ?
  12. Since PM6 also.
1 Like

Maybe this could be turned into a KDE Goal?