Plasma task manager and desktop stopped working

My entire Desktop went blank. All symbols are gone (I can still see them on ls ~/Desktop and in Dolphin) though the background is still the same.
I cannot open any applications via the task bar: a rectangle around the symbol appears and it’s loading for a couple seconds like when you open it normally, but then it just returns to the usual nothingness as if I’d closed it. Starting applications from a terminal or through Krunner still works fine and is also displayed accordingly on the task bar, and I can still use it normally to interact with running apps.
At the time where this appeared, I wasn’t doing anything special. Just being on Github in Firefox I believe.

I had the same (or a very similar at least) issue already a year ago. Back then I couldn’t find a nice fix, so I eventually emptied my homefolder which fixed it, at the cost of having to recover all my settings manually. Just copying the folder over again would make the problem reappear.
If someone has an idea what caused this, I’d be happy to skip the full recovery this time. Otherwise, I guess I’ll have to do binary search copying the settings files back…

Does the issue persist if you restart plasmashell or reboot the system?
Which Distro are you using?

Does this happen in both X11 and Wayland?

Can you post your logfiles?

Yes, the issue persists on reboot/restarting plasma
I’m on Arch.

This happened in X11. Just switched to Wayland, and here everything seems to be fine.

Which logfiles do you need?

Consider posting this on the Forum of your distribution. Especially if you run regular Arch, since they have imo the best support forum. I will try to help as best as I can, but you probably have better chances there.

Journald and xorg logfiles

Alright, can also try this.
Tbh since it’s fine under Wayland I’d be happy with that, but unfortunately ibus-anthy doesn’t really work well under Wayland, so I’d still prefer to get X11 fixed.

Here’s the logs for now.
This is the journal for a boot in which I did the following:

  • Boot and log into X11
  • Attempt starting Dolphin and Firefox from taskbar (both failed)
  • Attempt starting Telegram messenger from taskbar (this actually worked and I later tested that this is the only app I’ve found so far which can still be started from taskbar)
  • shutdown

Here’s /var/log/Xorg.0.log:

(wasn’t sure what to do with long files like this, so sorry for gdrive upload)

Possibly the same issue as How to stop KDE from forgetting all of my activities settings

Since you also have Jul 25 11:25:36 Providence plasmashell[1294]: Aborting shell load: The activity manager daemon (kactivitymanagerd) is not running.

So I finally got around to do some binary search on the config files, which fortunately didn’t take nearly as long as expected. I narrowed this down to the ~/.config/plasma-org.kde.plasma.desktop-appletsrc
At the very end, it contained the following section:

screenMapping=desktop:/DanMemoDiscordBot/.git/objects/c7,0,11386c69-14f5-424b-afcc-0f50a9b1a329,desktop:/Media/WhatsApp Voice Notes/201933/PTT-20190812-WA0003.opus,1,11386c69-14f5-424b-afcc-0f50a9b1a329,desktop:/Media/WhatsApp Images/Sent/IMG-20221126-WA0004.jpg,1,11386c69-14f5-424b-afcc-0f50a9b1a329, [...]

I shortened the last line here, because it was almost 2 million characters long!
Deleting it and then logging in again fixed the problem.

I have no idea what caused this, and I don’t know whether this was simply too long to handle for the system, or if there was any specific input within that line that broke it.

I kept a copy of the file before I changed it though, and will ask a friend to confirm reproducibility for me.
In any case, do you think this warrants a bug report or something?

Glad it works for you now!

Not an expert but I think its worth it! Worst case they close it or tell you to report it elsewhere, best case they fix an issue.

Can you please check your journald logs again if you still have the error message:

sudo journalctl -b | grep kactivitymanagerd

Aborting shell load: The activity manager daemon (kactivitymanagerd) is not running

Probably unrelated: You can fix this error in your xorg log: systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
by following xinit - ArchWiki
Although I am unsure if that has any benefit.

Yeah, that’s worthy of a bug report. If the line gets so long that it’s causing Plasmashell to crash then it either needs to be regularly truncated by whatever is writing it.

Yes, the error still appears.

No idea, but will do : )

Thanks for the help!

I will make a bug report later :+1: