Plasma6: Spectacle window is no longer hidden during recording


since the update to Plasma6, the Spectacle window is no longer hidden during a recording. This means that the Spectacle window is always visible during a full-screen recording. When recording a rectangle, Spectacle must always be moved out of the area to be recorded.

I’m still on X11 and using an AMD graphics card with amdgpu driver.

I tried to uninstall Spectacle, renamed the config file ($HOME/.config/spectaclerc) and installed spectacle again, but this didn’t help.

The problem doesn’t occur for another user who never used Spectacle before.

This is an example of a rectangular screenshot while Spectacle is still visible on the screen.

Do you by any chance have compositing turned off? If so, does the issue go away if you turn it on again?

Yes and yes! Thank you!

“Enable on startup” was disabled for compositing. However I’m sure that I did not change it after upgrading to Plasma6. So, either compositing was turned off by the update or Plasma5 behaved differently.