Plasmashell Crashes after login (Black screen)

Hello,

I’m running Nobara KDE with all the latest updates installed. All was working pretty good, except lately I started getting visual glitches, stuttering when scrolling on the web, etc. I figured it could be because of the theme I had installed, so I tried to switch back to default Breeze / Dark. Unfortunately, it wasn’t able to switch back properly. I figured a reboot should solve it, but unfortunately it made it much worse. I get the login screen fine, but when I log in to Plasma (wayland or x11, same result), I get the KDE loading symbol with the spinning thing, then it dims a little after about 10 seconds, then it goes to a black screen with a “plasmashell” crash message. I can open terminal with ctrl + alt + T and open programs, but I can’t launch plasmashell. I’ve tried different fixes listed by others, but those were all geared toward plasma5, so the folders don’t match up. For instance, this one seemed promising… I would link to it but the forum is saying I can’t post links:

" I got the problem solved! While I always thought the problem would be a system-problem because of the error pointing out a directory outside of the /home/user/ area (“/usr/share/…”), I was able to create another user and log into plasma with a perfectly fine new plasmashell.

So I decided to move ~/.kde to another location with the hope that plasma would start again - it did not.

Then I reset more of plama [(credits to Andreas Scherbaum’s description)]How-to-reset-your-KDE-without-deleting-everything-else.html) by doing:

~$ mkdir kde-backup/.config kde-backup/.local kde-backup/.config/session

~$ sudo mv .config/*plasma* kde-backup/.config

~$ sudo mv .config/*kde* kde-backup/.config

~$ sudo mv .config/*kwin* kde-backup/.config

~$ sudo mv .local/share/kded5 kde-backup/.local

~$ sudo mv .config/session/kwin_* kde-backup/.config/session

~$ sudo mv .gtkrc-2.0 kde-backup/

The folder kde-backup was only made for security purposes. I cannot say where the problem has exactly been but I am able to have a working plasma session again. The plasma configuration settings are lost - but I did not have a heavily customized plasma anyway. KDE Wallet still seems to be there though.

Hope this may help some other people experiencing similar issues in the futute…"

I was able to create a new user and log in, but now I’m stuck. I’ve done a nobara-sync and all that basic stuff to verify that everything was up to date.

Is there an easy way to completely reset Plasma 6 without requiring a reinstall?

I still get the visual glitches on the new user, which I think occured after a recent update. I have a Ryzen CPU and Nvidia GTX 1080. Its not the hardware (I dual boot with Windows).

I tried posting a link to the Plasmashell crash info but the forum is not letting me save my post after I edit it (error 422).

Thanks!

And that includes plasma6?

All I know about Nobara is that it is by gloriouseggroll, the prtoton-GE dude, and it is using some of the fedora stuff, but it already being on plasma 6 is a bit surprising to me.
Did nobara-sync give you the update?

Your post is a bit confusing, is the cursive text something you quote from somewhere else?

I assume you have tried this:
https://nobaraproject.org/docs/nvidia-troubleshooting/black-screen-after-update/

Yes, Nobara adopted plasma 6 pretty early after it was released - I was kind of surprised.

Sorry for the confusion. Yes, from the broken profile, nobara-sync gives updates, and has me reboot, etc, but it doesn’t fix the issue. I was already fully up to date with Plasma 6 and all available updates, and I can still do updates, but they don’t fix the issue. I can log into my new user profile and everything boots and works as expected, so its just my original user profile that appears borked for the time being.

By the way, restoring a Timeshift restore point doesn’t fix the issue either, and since by default I have it excluding my Home folder, I would assume that whatever needs to be edited / replaced would be in there.

What I was quoting was from a reddit post from another guy that has the exact same problem as me, although he was using Plasma 5. This forum is prohibiting me from posting links, I suppose because I’m a new user, so I had to just quote his text. You can find his original post by googling “black_screen_after_kde_plasma_login”.

The issue that I’m having is unrelated to the Nobara black screen issue with Nvidia cards. I know that issue, and have had it before on other machines, but that particular black screen prohibits any interacting with the system whatsoever, whereas with my current issue, I can log in and open up terminal and then open up virtually whatever program that I want from within terminal, I just have no desktop background, and no taskbar and an error that keeps popping about the Plasmshell crash handler. I’d love to post the crash info, but until my profile here is allowed to post links, I’m unable to do so.

When I try to add a link to my google drive to show you guys my crash info, I get a “error 422” message.

Ok, then we are on the same page.
Impressive, and ballsy to go for plasma 6 this early. Kudos to them!

And resetting your complete KDE did not work?
I assume that is what the text in the first post was?

I guess you learned the lesson on backups huh? xD

A silly question. Maybe all your stuff just got removed. Have you tried rightclicking > enter edit mode > add default panel?
Or are you saying nothing works?

Well I don’t actually know how to do a complete KDE reset, so if you know how to do so on Plasma 6 that would be great. The instructions for Plasma 5 don’t translate (the folders aren’t the same), and I don’t want to randomly start deleting stuff just because it says KDE on it not knowing what I’m doing.

I would love for there to be a Macrium type imaging program for Linux, but I haven’t seen it yet. Clonezilla is nice, but when doing a drive image it copies the free space as well, which makes backups huge, but yes, obviously a full system image would have been great here.

Right clicking is non-functional. I made a video showing exactly what happens. Just add the “t” in the http:

htps://www.youtube.com/watch?v=hILXOmNN7wE

Here is the crash data, again, just add the “t”:

htps://drive.google.com/file/d/13csyrfmlsiKOr9mzfTO2MV9Cy2q1yov6/view?usp=drive_link

Just copy the entire /home to somewhere, not more complicated than that, then start deleting like a wild man! xD

No it doesn’t, it does a complete copy (but empty blocks are just scanned afaik, not dd:d), so all empty space gets compressed down to a few kb, and the rest of the data ALSO gets further compression.
Not sure where you got that from.

How to reset the desktop entirely, I do not know, someone else can surely help you way better with that than I can.

But if you want to experiment, just copy /home.

I deleted everything KDE, Kwin, Plasma related that I could find in the .local and .config folders and the issue remains.

I’ve seen a lot of threads about Clonezilla where people mention that you can’t save an image to a smaller disk than the current one, so maybe I was confused by that.

Thanks for the suggestion staeglich, but I deleted all of my .desktop files in my desktop folder and the issue remains.

That is if you clone the device. lol
If you select device > image it shrinks it to minimum.

Why not delete the entire directory, and then copy from the newly created user that works, then take ownership of it all and start pulling your old stuff back one thing at a time?
No idea if it works, but if you have a complete backup of home, why not try.