Plasmashell crashes frequently after upgrading to Plasma 6.0

After upgrading my KDE neon User Edition to Plasma 6.0, plasmashell crashes frequently. I cannot figure out what triggers it. As I am working with numerous different applications, I notice that the Task Manager disappears, then reappears, and then I am prompted to submit a crash report.

This has happened about a dozen times so far today, and there is no pattern apparent to me so far.

I can continue working, currently it’s just a nuisance, but I wonder if others experience it too or whether it is something specific for my computer.

edit: It just now crashed while I was on the phone, with the computer just idling in front of me, no user interaction whatsoever.

3 Likes

Almost certainly the new Wayland default. You need to log out and change to X11 at the log in screen. Then reboot, or else set your system to auto-login using X11 using system settings.

I wish someone had concretely told me my issues likely were Wayland related before I spent so much time getting frustrated and pissed off with so many crashes.

Possibly default Ubuntu is an adequately mature implementation of Wayland. I don’t know because I haven’t tried it. KDE Neon seems to have a long way to go before Wayland can be considered ready for prime time.

If you do not follow the news that KDE is defaulting to Wayland, that is on you.
It has been talked on for at least a year.

Maybe so, but you choose to use it.

If you want to stay on x11, that as far as I understand it, support will be dropped, go ahead.
But recommending others without further information, that’s where I step in.

@bovender I’m sorry your experience is not good.
You CAN use x11, but I would recommend you try to find out why this is happening.
It’s a big ask, so if you prefer, you can use x11 (but there can be bugs there too) if the experience is better until whatever is going on has been solved.

Plasma 6 is brand new and being part of the absolute first testing crew always involves bugs in a huge project like KDE, that is just a reality.
In this situation the error could be caused by either Wayland or Plasma 6, or both. Or maybe it is some random small program causing this, only you can find these things out.

Not much more to do unless you can provide info on what is crashing.
If you f.ex open up KSystemLog there SHOULD be logs providing info on what is crashing.

No sweat :wink:

ksystemlog is a GUI to display /var/log/syslog, am I right? Anyways I’ll try and find some useful information in there today.

BTW @Salt84 Been using Plasma 5 on Wayland for everyday work for some time now and I’m quite happy with it. But yeah, X11 is still there as an alternative.

You can use sudo journalctl -e -f to tail the log live in a console.
But it might be a LOT of info, but if you have it open while it crashes maybe you can catch what is causing the crash.
You can then look it up afterwords by using grep, for example:
sudo journalctl -b 0 | grep -i 'kwin' (-i means ignore case sensitivity) or if it was previous boot, change -b 0 to -b -1

You can also check all errors with sudo journalctl -b 0 -p 3
or
sudo journalctl -b -1 -p 3 for previous boot.
-p 3 only displays errors, not warnings or anything else.
FYI, warnings can generally be ignored, it’s the errors you are looking for.

You can see all your boots with sudo journalctl --list-boots

Where did you find X11 setting using system settings ?
many thanks

Maybe related?

System settings > Colors & Themes > Login Screen (SDDM) > Behavior.

The log files in /var/log are kind of deprecated - as @bedna mentioned on modern Linux systems we use the Journal system with the journalctl command.

On of the best features of Journal is that you can get the logs of just that one software you are interested it - instead of trying to find this one important log in the torrent of everything that is running at the same time on your system.

For example, to look at just the logs for your Plasma shell in the last 5 minutes, one can run journalctl --user -u plasma-plasmashell.service -S -5min

See man://1/journalctl for explanation of what all those options mean, but I want to point out that the Plasma shell is running as a user service called plasma-plasmashell.service.

(note: that man:// link probably won’t work in your browser, but try pasting that in the Plasma kickoff menu, or krunner by pressing META+Space)

We need a backtrace of the crash to debug it. See Guidelines and HOWTOs/Debugging/How to create useful crash reports - KDE Community Wiki. I’d recommend doing that and then submitting a bug report.

I wont use Wayland either. It does not work properly on my rig. X11 does. It seems a lot of people still have a lot of issues with Wayland, and I agree, it is not ready for primetime.

1 Like

Good catch.

As for journalctl man pages, I use these: journalctl(1) - Linux manual page

Could be good to know that ctrl + c exits the log back to your prompt (if it is being tailed for example).

1 Like

Thanks all, I guess we can close this discussion (which is getting quite off-topic) and I’ll open (a) bug report(s) once I have enough information. I’m very time constrained though.

What I can tell so far is that there are at least two issues,

  1. akonadiserver throws tons of exceptions within one second before plasmashell crashes & once I disabled the calendar plugin in the Digital Clock/calendar widget, those random crashes no longer occurred;

  2. reproducible crashes when I wake my laptop from sleep.

As I wrote, I’ll create bug reports for the developers once I can gather more useful information (backtrace etc.).

Oh and maybe I will change my old habit of analyzing log files with less after all :wink:

1 Like

I also experience plasma shell crashes when walking up from sleep. My bug report is here: 482188 – Shell crashes in KWindowShadow::destroy() when unlocking the screen after idling for a while

1 Like

I’m also experiencing crashes - mostly when waking up from sleep, but sometimes while in use.