Prevent Notifications from Stealing Focus (KDE on Wayland)

How do I prevent KDE notifications from taking focus from my current app? I was just renaming a file in Dolphin, and a notification popped up that took away the focus from Dophin. This is very bad behavior, and should generate a bug report imo. I almost lost a file, and the only reason I didn’t is because I typed a space in that file which was the only character that made it different than another file in the same directory. Dolphin may have prompted for confirmation, but notifications should not steal focus.

You’re going to have be more specific, what kind of notification? KDE notifications should not steal away focus, so if they do you should file a bug report on

1 Like

In this case, it was a notification that a DVD I’d just inserted into the external DVD drive was ready. It does that on pretty much any external storage medium I load now that I think about it.

Do you have a screenshot of what it looks like?

Ah I get it now, that’s not really a notification but the devices applet. You can disable this functionality by right-clicking it and disabling the popup when a new device is connected.

1 Like

I wasn’t able to get it by right-clicking, but I was able to fix it with the hamburger menu. This is why I come here before creating bug reports.

There are some bugs regarding multi-monitor setup (at least on Wayland, though I’ve never used KDE on X11).