Problem running digikam, kdenlive, and showfoto on M1 Mac


I have a M1 Pro (2021 MBP) running Monterey (12.6.4) that I’m not able to run some KDE apps. This worked up until a couple of weeks ago, and the only thing that I remember changing was updating brew.

These apps all hang on the splash screen with a spinning beach ball. The apps say “Application Not Responding” and to exit a “Force Quit” has to be done.

Digikam 7.10.0
Showfoto 7.10.0
Kdenlive 22.12.3

Sometimes, kdenlive will display a message “Kdenlive crashed on last startup. Do you want to reset the configuration files?” However, the application is hung and no buttons on the dialog work.

The interesting thing is that this only happens for one user. I created a dummy account on this same box and I was able to run all three apps!

I have tried to turn on debugging with QT_LOGGING_RULES but nothing jumps out at me. For example, the last message from digikam:

2023-04-12 23:21:00.190373-0600 digikam[45387:5514516] [qt.qpa.fonts] Populating font family aliases took 291 ms. Replace uses of missing font family “.AppleSystemUIFont” with one that exists to avoid this cost.

I also tried removing some config files to reset my environment, but I couldn’t find anything that seemed to cover all three apps.

Any advice on how to narrow this down would be greatly appreciated.