Problems booting, casual user confused by kernels

i’m using kubuntu as my daily driver for a while now, i’m currently on 23.04 with an nvidia gtx 1060 gpu. So far it worked without any major issues.
But yesterday there seemed to have been an update with kernels. I updated and shut down. Today i couldn’t boot anymore with an error in the boot process for vmware.service …something with lsb.
I tried looking it up but i couldn’t find any useful info.
As i’m not that deep into linux i tried random things. First i selected recovery mode in grub and in root terminal uninstalled vmware player. This got rid of the error, but then it was just stuck after some other [OK] message; no sign of any issue, just stuck.
After trying again a few times i noticed that in the recovery menu there were a few kernel options listed that i hadn’t seen before, something with -lowlatency and -oracle at the end.
Interestingly the generic one that i’m sure was always there was at the end of the list.
When i select that one it boots just fine, so i assume it uses the -oracle one by default which is the first in the list.
Now, i’m not sure how i can fix this situation. I found that i could change something in some grub configuration to make the generic option the default again, but i’d rather make sure i have a clean system which uses the correct one by default.
I’m not sure why i have these other kernel options and how they got there, or how an update changed everything.
Can someone help me understand and fix this?

I recommend that you ask on the Ubuntu/Kubuntu support channels, since this seems to be a Kernel issue and not KDE specific. They are more likely be able to help you.

OK, makes sense, i just wasn’t sure if this had something to do with whoever controls the updates and i was under the impression that KDE was related.