Problems with KDEneon Live-Stick

Hello Community,

I need help for a new installation of KDEneon on a LENOVO T14 Gen3 laptop using a live USB stick. I have created the USB stick as root with the following command:

dd if=./neon-user-20240215-0716.iso of=/dev/sdd bs=10M

Unfortunately, the laptop does not boot from this USB stick. If you press F12 on the LENOVO laptop, you can select the temporary boot device. The stick is recognized there and you can select it, but after selecting this menu item it jumps back to the menu after a short time and does not boot.

How can I get the laptop to boot from the KDEneon live stick so that I can install the system on the disk?

I have created the same USB stick with the program “ISO Image Writer”, but even so I could not boot from the USB stick.

Do I have to change anything in the BIOS settings?

Greetings
Michael

Isn’t the recommended block size 1M?
Did you check the correctness of downloaded iso image? Maybe failed download?
I have never had problems booting neon live media at my ThinkPad X260 or X1C laptops…

1 Like

This smells like a secure boot issue. In fact about two weeks ago I had a laptop come into my shop that did this.

Try this:

Failing this, I would turn off secure boot in the BIOS and give it another shot.

Hope that helps.

1 Like

Hi cmdrkotori,
I have solved the problem. If I only switch off “Secure Boot” completely, the laptop can boot from the USB stick.

The document you mentioned from LENOVO leaves Secureboot on and only enables “Allow Microsoft 3rd party UEFI CA”. In both variants, the USB stick then boots the live system.

However, I do not know which is the better variant under Linux. Completely without “Secure Boot” or with activated “Secure Boot” and “Allow Microsoft 3rd party UEFI CA”?

Thanks for your help.

Greetings
Michael

Really good questions.

I have opted to disable secure boot, but I know there are ways of having it active, but I just have not looked into it. I feel the risk of me getting “hacked” or infected with anything is very small if I follow procedure with crc checks of firmware I use when updating.

I DID forget to disable it on a laptop I installed on recently, but after a while it created problems for me so I disabled it rather than learning what to do to actually have it active.

I did use ventoy when installing on that laptop though, and I think that had something to do with it even booting from the stick in the first place with secure boot active.
Ventoy is all I use now, it is soooo much more convenient than locking up a whole stick with one single img. Also not having to slowly dd every da*n time save so much time.

Then there is also the MBR vs GPT partition table to always consider, but since your bios detected the stick, that was not an issue in this case.

Hopefully someone else with more knowledge will ship in with some info here.

I had similar problems with an old Lenovo Ideapad Flex 15 D.

Blanc screen only.

In my case disabling Secure Boot did not help.

Problem was solved by setting Legacy support ON and Legacy First in UEFI/BIOS settings.
[This setting also made Secure Boot inactive (disappear) in UEFI].

If your UEFI does not have above mentioned option - problem is also solved by setting boot mode to BIOS only in UEFI/BIOS. Solution is from here:

https://www.reddit.com/r/kdeneon/comments/yn3kcd/tip_if_you_cant_boot_kde_neon_on_thinkpads_set/?rdt=65155&onetap_auto=true&one_tap=true

Installed system: KDE neon 6.0 - Plasma 6.0.2

P.S. I think the problem is somehow Lenovo related, since the same usb ISO booted just fine in a HP laptop - in pure UEFI mode.

I made the iso with: # cat /path/to/iso > /dev/sdX , where X is naturally partition of the usb-stick.

P.S. P.S. I have tried installing Neon before to this machine - first time over ten years ago - and never succeeded. Finally I found the solution and got it right!

Sounds like you are running that with MBR and uefi and not GPT and uefi.
Will still most likely work without you noticing, but it can create problems.
The installer has to make a couple of empty MiB before boot partition, but should not be a problem. (not sure what installed Neon uses, but calamares should fix this for you)

Most likely yes.
See if you find something called CSM in bios and disable it (not always present), that could fix it.
If not, just run it it legacy, no biggie.

It’s GPT alright. Before install I wiped the whole harddrive with fdisk by creating a new GPT partition table. Now after install I double-checked with Gnome Disks-program.
So the install is legacy with GPT.

The Neon installer duely noticed this and reported that with GPT and Legacy mode an 8 Mb unformatted partition with /boot/grub-flag must be made - in order to have a successful install.

The installer looked like a mixture of Calamares and the one that Kubuntu uses…

Pretty sure that is MBR, not GPT, but am prepared to be proven wrong.

Easy way to find out: (change sda to the device, not partition, that your root resides on)
sudo parted /dev/sda print | grep 'Partition Table'

It will return either gpt or msdos

But again, unless you know this to be a limitation, it most likely won’t.

I just found out my USB-stick is with MBR partition table!

Maybe that’s the reason… But still, the HP booted allright - and it does not even have a Legacy option at all.

I’ll make a new GPT usb iso-live and reinstall KDE neon with it.
I’ll inform here what happens…

P.s. sudo parted /dev/sda print | grep 'Partition Table' gives gpt.

That doesn’t matter.
If you use ventoy for example it will always be mbr (a big I THINK here) even if the iso itself is gpt partition table. And some ISO:s are still hybrid.

What I am asking you is: What partition table is created by the installer on the root device if you choose:

As I understand it this was the ONLY way you could get it to work on your Lenovo?

What is the full output of sudo parted /dev/YOUR_ROOT_DEVICE print AFTER a successful installation?
Reboot with the stick removed so there is no risk confusing anything. :slight_smile:

sudo parted /dev/sda6 print | grep 'Partition Table'

gives loop, sda6 is / -partition of Neon. (The machine has also another OS - Ubuntu 22.04 LTS).
This I do not understand - sda6 is partitioned to xfs-format.

The usb-stick is in another computer - not in this one.

Correct - It was the only way to make it happen.

… I have not checked the SHASUM of the iso-file…

You seem to have something very funky going on in general there.

I’m sorry, this is beyond my knowledge.
It was a very long time since I ran Ubuntu and have never ran Neon, so I do not feel comfortable advising about this.

I was under the impression this was a fresh install with single OS.

Never mind…
Thank you for your help.

I would still like to know what is supposed to be outcome of the command
sudo parted /dev/sda6 print | grep 'Partition Table' when it has a xfs-partition. (All the Ubuntu (fxs) partitions and EFI-partition also give loop with this command).

I told you to run it on the DEVICE, NOT the partition. Use:
sudo parted /dev/sda print | grep 'Partition Table'

A partition table is for the entire device (disk), not for each separate partition.

But in this case nothing of that matters, because Ubuntu created the partition table, not what you are doing now.
Well, it matters because if it IS gpt, you should probably just install neon as gpt/uefi because the partition table supports that. But since I have not ran the systems in question, and you have xfs filesystem, I can not advice further.

Perhaps You missed my earlier comment…

… but I thank You again for your kind help.
Since Neon OS works as expected even as it is, there is no major problem…