Problems with partition manager

After a fresh KDE Neon install I found the following trouble:

I installed parttitionmanager fron the konsole (sudo apt install partitionmanager). No from root.

When I launch it I get an error. ( sorry if it’s not exact. I translate from catalan).
“The partition manager requires privileges in order to work. Update devices and authenticate when prompted”.

If I click on “update devices” nothing happens.No devices are listed.

If I try to launch partitionmanager from terminal, with “sudo partitionmanager” I get:

Authorization required, but no authorization protocol specified
qt.qpa.xcb: could not connect to display :10.0
qt.qpa.plugin: From 6.5.0, xcb-cursor0 or libxcb-cursor0 is needed to load the Qt xcb platform plugin.
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the applicat
ion may fix this problem.

Available platform plugins are: eglfs, vnc, wayland-egl, vkkhrdisplay, wayland, linuxfb, xcb, offscreen, minim
alegl, minimal.

By other hand, gparted works normally.

Any Idea for solution ?

is it a flatpak?

if so, maybe install flatseal and see if you can finagle the permissions to get it to what you want.

This is no error but more of a notice/requirement: you need to enter your password to gain elevated privileges so the KDE Partition Manager can execute operations regarding your drives and partitions.
It is the same procedure as for e.g. GParted.

Start the KDE Partition Manager from the Application Launcher and just enter the same password that you would enter for a command used with sudo in Konsole.

Partition manager won’t run under sudo.

To run Partiton Manager from the CLI type


then enter you root password in the Dialog box that requests your password.

It will then function normally.

This is a Security Policy setting I believe

If I run partitionmanager in a terminal without sudo or I run it from the menu I have the sape result:
“The partition manager requires privileges in order to work. Update devices and authenticate when prompted”.

No devices are listed. If I update devices list clicking the button, nothing hapens. No devices are listed.

By other hand, in a Kubuntu machine, If I try to run “sudo partitionmanager” in a terminal. I can work fine with no permission requirement.

KDE neon is plasma 6 and Kubuntu is plasma 5

By any chance is the auth window appearing behind the Partition manager window so you can’t see it without manually bringing it forward?

If not, then it seems that polkit on your system is broken.

1 Like

Is it possible to restore polkit?

I did:
sudo apt install polkit-kde-agent-1

And it’s solved

Thanks for your help!

That definitely should have been pre-installed. Please report this as a bug to KDE Neon at Thanks a lot!

I installed Neon in a VM just yesterday (to check that sddm wayland issue), polkit-kde-agent-1 is a dependency of plasma-desktop already. :person_shrugging: :thinking:

1 Like

Thanks. Perhaps it was just fixed recently, then. Or perhaps there was some kind of local misconfiguration affecting @asf.

1 Like

has happened to me multiple times with application X and Y and Z …

just yesterday LibreOffice opened the restauration dialog even on a different virtual desktop.

multiple obvious problems with getting the active screen. i’m used to and can handle it :wink:

is there where the Focus stealing setting prevention comes into play?

mine is set to low and i still occasionally find an app unresponsive because their is a dialog open BEHIND it.

should i try setting it to none or extreme?.. not really sure what this does.