Reaper Window Can't Be Enlarged in KDE Plasma using Wayland

Reaper for Linux opens OK if I select X11 from the login menu but not if I leave it as the default: Wayland. The Window is small and can’t be enlarged or maximized. Fresh install of Debian 12 - KDE Plasma and Reaper for Linux v7.18. I have had the same experience with Mint and Reaper v7.16 too.

1 Like

I’m not sure what “Reaper” is, but it sounds like it has partial support for Wayland that is broken in some way.

I recommend (A) reporting it to the Reaper developers as a bug, and (B) you can maybe workaround that in your local Wayland session by forcing the application to run under XWayland - the X11 compatibility mode in Wayland. To do that:

  1. Find the shortcut to the application in the application launcher (“Plasma menu”, “start menu”, whatever).
  2. Right click the launcher and choose “Edit application…”
  3. In the dialog that opens go to the “Application” tab.
  4. In Environment Variables type WAYLAND_DISPLAY=.

Should look like this:

  1. “OK” the dialog.
2 Likes

Thanks for the reply. Reaper is a popular DAW (Digital Audio Workstation) used for music recording and production etc. I tried the work around you suggested, but no window would open at all, and I had to reboot to reset it. I posted in the Reaper forum some time ago but as yet have had no reply: Thread=291616.

1 Like

Why? This was a simple change to the application launcher - you can just change it back and it should launch as before.

There is probably something a lot weirder going on. I tried to download and run Reaper from their website and it looks like it has no Wayland support - it runs under XWayland, so it shouldn’t respond at all to unsetting WAYLAND_DISPLAY.

I’ve tried to force it to use Wayland by unsetting DISPLAY (which specifies the port to the X11 protocol server) and then it starts but won’t show any display at all - which tells me that their toolkit implementation is severely broken - if the GUI client cannot connect to the display it should abort and exit.

Normally I’d ask you to run the client from the terminal and report what output it shows, but from my tests - in either case there is no usable output about the display situation: it only logs output related to connecting to the Jack service.

If you get help from the Reaper forum and find a solution - I’d appreciate it if you can post it here - for the next person that comes knocking :slight_smile: .

Wow! Thanks for taking the time to look into this. I really appreciate it. Running it from the terminal didn’t yield anything, like you suspected. I think that I couldn’t reset it before because it was running without a visible window. I probably could have killed it from the terminal but thought that it would be just as easy to reboot. Hopefully, they will resolve the issue in time, especially as Wayland is now becoming more widespread.

This is likely - from my tests when it runs and doesn’t show a window, it doesn’t exit and continues running (as I’ve mentioned before) and a lot of applications have a “unique instance” behavior where there is only one instance running and if you try to run another one it instead messages the first one to do whatever “launching again” means. Firefox does this and it is such a common practice that KDE Frameworks and Qt has a specific helper implementation for that.